
        

       LaboTex 
                  Version 3.0 

                   

   Texture Analysis Software for Windows 

 

 

 

   

 

  

 

Introduction to LaboTex 
 
 

LaboSoft s.c. 

Phone: +48 502 311 838 

Fax: +48 12 395 3891 

E-mail: office@labosoft.com.pl 

© LaboSoft  1997-2019 

V-3/55 



 2 

 
 

Contents 
 

1. Introduction ................................................................................................................... 4 

1.1. Main Program Features....................................................................................................................... 4 

1.2. LaboTex -  Range of Applicability ..................................................................................................... 5 

1.3. Representation of Orientations by Euler Angles. ............................................................................... 5 

1.4. Crystal and sample coordinate systems: LaboTex Axis and Angles Convention. ............................. 6 

1.5. ODF definition .................................................................................................................................... 7 

1.6. Basic ranges of ODF. LaboTex structure code. .................................................................................. 7 

1.7. Pole Figures ........................................................................................................................................ 8 

1.8. The ODF Calculation .......................................................................................................................... 9 

1.9. Definitions of fit error in ODF calculation ......................................................................................... 9 

1.10. Qualitative Texture Analysis .......................................................................................................... 10 

1.11. Modelling of ODF, pole figures and inverse pole figures .............................................................. 10 

1.12. Quantitative Texture Analysis.  I - Volume fraction of texture components by integration methods 

(IM). ................................................................................................................................................ 10 

The overlapping problem .............................................................................................................. 11 

1.13. Quantitative  Texture Analysis.  II - Volume fraction of texture components by Model  Function 

Methods (MFM) .............................................................................................................................. 12 

1.17.  2D and 3D Graphics ...................................................................................................................... 13 

1.18.  Detailed Manuals  (www.labosoft.com.pl and www.labotex.com) ............................................... 14 

1.19.  ADC method: Opinions and Applications ..................................................................................... 15 

 

2. Getting started ............................................................................................................. 16 

2.1. System Requirements ....................................................................................................................... 16 

2.1.1 Minimal requirements:..................................................... Błąd! Nie zdefiniowano zakładki. 

2.1.2 Recommended system configuration:.............................. Błąd! Nie zdefiniowano zakładki. 

2.2. Installation ........................................................................................................................................ 16 

2.3. Configuration .................................................................................................................................... 17 

 

3. LaboTex Objects and Object Containers ................................................................ 18 

3.1 Introduction ........................................................................................................................................ 18 

3.2 LaboTex Objects Types ..................................................................................................................... 20 

3.2.1 CPF - Corrected Pole Figures .............................................................................................. 20 

3.2.2 NPF - Normalized Pole Figures ........................................................................................... 20 

3.2.3.  RPF - Recalculated Pole Figures ....................................................................................... 21 

3.2.4.  APF - Additional Pole Figures .......................................................................................... 21 

3.2.5.  INV - INVerse pole figures ............................................................................................... 21 

3.2.6.ODF - Orientation Distribution Function ............................................................................ 22 

3.3. Example CPF, NPF, RPF objects ..................................................................................................... 22 

3.4. LaboTex Jobs .................................................................................................................................... 23 

 

4. LaboTex Formats ........................................................................................................ 24 

4.1. EPF file format ................................................................................................................................ 24 

4.2. EPF Example .................................................................................................................................... 25 

4.3. PPF file format .................................................................................................................................. 26 

4.4. SOR file format ................................................................................................................................. 26 



 3 

4.5. POW format ...................................................................................................................................... 26 

4.6. COR format ...................................................................................................................................... 27 

4.7. Other data formats ............................................................................................................................ 27 

4.8. How make given format accessible for LaboTex ............................................................................. 33 

 

5. LaboTex - Frequently Asked Questions (FAQ) ........................................................ 38 
 

6. References ..................................................................................................................... 47 

6.1 The LaboTex Reference: ................................................................................................................... 47 

6.2 ADC Method - Main References: ...................................................................................................... 47 

6.3 Other selected references on LaboTex and ADC: ............................................................................. 47 

6.4  ODF Transformation references ....................................................................................................... 71 

6.5  Calculation of the Volume Fraction of Texture Component and the ODF Modeling  references ... 71 

6.6 Measurement of Pole Figures references ........................................................................................... 72 

6.7 Texture and Quantitative Phase Analysis references ......................................................................... 72 

6.8 Texture and ODF references .............................................................................................................. 72 

 

7.  LaboTex: Technical specifications ............................................................................ 72 

 



 4 

 

1. Introduction 

 
 

 

 

 

 

 

 

 

 

 

 

 

1.1. Main Program Features                                

 

LaboTex software is a Windows 2000/XP/2003 tool for complex and detailed analysis of 

crystallographic textures. This user-friendly program enables you to conduct a variety different 

calculations and graphic analyses of Orientation Distribution Function (ODF), Pole Figures 

(PFs) and Inverse Pole Figures (IPFs). The main LaboTex features include: 

 

 ODF calculation by ADC method with the ghost correction; 

 ODF free from truncation errors of the series; 

 ODF calculation using both types of experimental data: pole figures and sets of individual 

orientations; 

 ODF, PF and IPF data measured, calculated and presented in a wide range of grid cells 

from radial angle 1.0 to 10 degrees with a background and defocusing correction;     

 texture analysis of all types of sample symmetry;  

 a fiber texture analysis; 

 a texture analysis for materials of all types of the crystal lattice symmetry; 

 2D and 3D graphic presentation of ODFs , PFs and IPFs; 

 simple on-line identification of the orientations, giving its parameters  in Euler angles and 

Miller indices; 

 creation of additional pole figures and inverse pole figures; 

 creation of misorientation histograms; 

 creation of model ODF on the base of model functions (Gauss, Lorentz); 

 comparisons of ODFs and PFs (up to 12); 

 diagrams for the skeleton lines (alpha fiber, beta fiber etc.); 

 an on-line qualitative texture analysis;  

 a texture database; 

 a quantitative texture analysis: the volume fraction of texture components by a model 

function and integration in the Euler space; 

 ODF transformations (frame rotations, crystallites rotation models);    

 ODFs logical functions (sum, union etc.); 

 transformations of ODF to a set of single orientations;  

 input data in more than 30 data formats; 

 rotations and symmetrizations of experimental pole figures; 

 plotting graphics on  mono and colour printers; 
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 passing graphical objects to other Windows applications via the clipboard or creating image 

files in the *.BMP or *.TIF format; 

 exporting ODF and pole figures to the ASCII format; 

 easy management of the data and results by collecting in symmetries, projects, samples and 

jobs. 
 
 
 
 

1.2. LaboTex -  Range of Applicability 
 
 

LaboTex is a versatile piece of software which can be used to handle: crystallographic textures 

of materials such as metals and alloys, ceramics and composites, semiconductors and 

superconductors, polymers and rocks. 

 

All these materials can be: 

 of all types of the sample symmetry : 

 

1) orthorhombic, 

2) monoclinic,  

3) triclinic, 

4) axial, 

 

 of all types of the crystal lattice symmetry : 

 

1)   triclinic (symmetries after Schoenflies: C1), 

2)   monoclinic,    (C2), 

3)   orthorhombic  (D2), 

4)   trigonal      (D3, C3),  

5)   tetragonal    (D4, C4), 

6)   hexagonal     (D6, C6),  

7)   cubic (O, T). 

 

1.3. Representation of Orientations by Euler Angles.                                         
 

Crystal orientation is commonly described by three Euler angles. The three Euler angles 

(,are defined in the space of  0 - 2 for  , 0 -  for  and 0 - 2 for . The 

orientation is described by the rotation that transforms a sample fixed coordinate system into a 

crystal-fixed coordinate system of a crystallite. The orientation can be described by three 

counter clockwise partial rotations:  

(a) the crystal coordinate system is rotated by  angle around Z axis of the sample     

coordinate system, 

(b)  then it is rotated by  angle around X axis (in a new position) of the crystal coordinate 

system, 

(c)  Finally it is rotated by  angle around Z axis of the crystal coordinate system. 
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1.4. Crystal and sample coordinate systems: LaboTex Axis and Angles 

Convention. 
 

 

[100]

[001]

[010]

Z

X

Y

  
  

 

Figure 1 

 

LaboTex uses the following convention of the axis for fixing the crystal and sample coordinate 

system (Figure 1) : 

 

1. X,Y,Z axis are perpendicular to each other. 

2. [100] axis is in XZ plane. 

3. Z axis is paralel to the [001] crystallographic axis. 

4. The crystal coordinate system and the sample coordinate system should be at the 

same order i.e. both right-handed or both left-handed. 

5. Bunge definition of Euler angles: 

 

 where X,Y,Z  - the axis of the crystal coordinate system, 

            [100], [010],[001] - the crystallographic axis. 
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The exception is the hexagonal system for which user may to choose axis convention A or B 

(Figure 2) : 

 

 

 

 
 

            Figure 2 

 

 

1.5. ODF definition                                                                                                  
 

The Orientation Distribution Function (ODF) is defined as: 

 

                                        dggf
V

dV
)(  

where : 

)(gf  - values of ODF; 

g()  - orientation; 

dV  - the volume of crystallites with the orientation g in the element of the orientation space   

dg = sinddd where are Euler angles; 

 V  - the sample volume.  

 

 

1.6. Basic ranges of ODF. LaboTex structure code.                                 

 
LaboTex shows ODF in a reduced basic range. The Euler angle space can be reduced due to the 

crystal and sample symmetries. The boundaries of the basic range of ODF in the Euler space 

and symmetry structure code used in LaboTex are collected in table below: 

 
Symmetry Cubic** Hexagonal Tetragonal Trigonal Ortho-

rhombic 

Mono- 

clinic 

Triclinic 

O T D6 C6 D4 C4 D3 C3 D2 C2 C1 

LaboTex 

structure code 

7 6 11 10 5 4 9 8 3 2 1 

 

1 

 

 

triclinic*         (C1) 360o 360o 360o 360o 360o 360o 360o 360o 360o 360o 360o 

monoclinic*    (C2) 180o 180o 180o 180o 180o 180o 180o 180o 180o 180o 180o 

orthorhombic*(D2) 90o 90o 90o 90o 90o 90o 90o 90o 90o 90o 90o 

axial* -*** - - - - - - - - - - 

 90o 90o 90o 180o 90o 180o 90o 180o 90o 180o 180o 

2 90o 180o 60o 60o 90o 90o 120o 120o 180o 180o 360o 

* - sample symmetry 
** - there are three non-linear basic regions inside the described region  

*** - for any 1 angle 

The structure code is introduced to experimental data files (EPF,POW,PPF...). 
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1.7. Pole Figures                                                                                                      
 

The experimental pole figures are obtained via X-ray and neutron measurements. LaboTex pole 

figures processing comprises of the correction of the pole figures on account of their 

defocusing and background, as well as the preliminary normalization and the possibility of 

different kinds of symmetrization. ODF calculation from the pole figures is one of the main 

areas of applications of LaboTex. Experimental pole figures are unnormalised i.e. the measured 

intensities depend on the type of X-ray or neutron  source, on the type of a counter, the 

collimating system, the absorption properties of measured material and so on. Therefore 

experimental pole figures cannot be compared with each other. Pole figures can be correctly 

normalized only in the ODF calculation process. There are three types of pole figures, from 

point of view of normalization, used in LaboTex: 

 

  i - unnormalized 

            ii  - approximately normalised 

            iii - precisely normalised. 

 

Pole figures (also max. intensities) from the experimental pole figures (i and ii) usually have 

different intensities than type iii pole figures. All comparisons between pole figures should be 

conducted inside type iii pole figures. Quantitative analysis can be done using only normalised 

pole figures. 

 

 

 

 

 

 

 

 

 

 

 

 

You can find more details in the LaboTex manual:  

“Pole Figures: Registration and Plot Conventions” available from our websites:  

www.labosoft.com.pl or www.labotex.com 

 

 

http://www.labosoft.com.pl/
http://www.labotex.com/
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1.8. The ODF Calculation                                                                              
 
 

The orientation distribution functions determined using LaboTex are ghost corrected. In 

comparison with the method of the ODF reproduction based on Fourier series, the results 

obtained using LaboTex are free from truncation errors of the series. Obtaining these error-free 

results is of great importance when very sharp textures are analyzed. LaboTex  calculates the 

ODF using both types of experimental data: 

 

 ODF calculation from Pole Figures using the ADC method [1-10]. The algorithm of the 

ADC method used in the program has been verified using a large number of models and 

experimental data. The results were published in many papers and proceedings (see 

ADC Method on www.labosoft.com.pl/adcmethod ). LaboTex reproduces the 

orientation distribution function with a great precision in a wide range of texture 

sharpness (from textures close to the random distribution to those of deformed single 

crystals). ODF can be calculated from complete and incomplete pole figures (measured 

in an arbitrary range of a radial angle).  

 

 ODF calculation from a set of individual orientations. The number of individual 

orientations may be arbitrary. Individual orientations may be weighted or not. 

Individual orientations should be given in Euler angles (degrees or radians are valid). 
 
 

1.9. Definitions of fit error in ODF calculation                                                    
 

The texture index and definitions of fit error RP (controlling the iteration procedure of ODF 

calculation) are defined as: 


G

dggff )(
8

1 2

2

2


 

where : 

2f  texture index, 

)(gf  value of ODF, 

g  orientation, 

G - orientation space. 

 

   

 
%100

1

1 .exp

..exp



 



N

i i

icalci
hkl

PF

PFPF

N
RP  

where : 

}{hklRP  - relative error for {hkl} pole figure, 

 
i

PF .exp - intensity of experimental (corrected and normalized) pole figure in 

             point i, 

 
icalcPF .  - intensity of calculated pole figure in point i, 

N  - number of measured points on pole figure. 





M

j

hkl j
RP

M
RP

1

}{

1
 

dRP – absolute change of RP between successive iterations. 

 

 

 

 

 

http://www.labosoft.com.pl/adcmethod
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1.10. Qualitative Texture Analysis  
 
 

The Identification of the orientation using cursors, giving their parameters in Euler angles and 

Miller indices, can be done on the PF and ODF.  The identification of the orientation on the 

different types of objects (PF and ODF) is possible simultaneously in the Compare mode. The 

Compare mode is very important for education (the interdependence of orientations on PF and 

ODF).  The values of PFs and ODFs are shown in the points chosen by the cursor.  The 

orientations are optionally collected by users from the orientation data base. Users can add, edit 

and delete the orientations from the database. The orientations can be entered in a form of 

Miller indices (HKL UVW) or Euler angles (). There is an option to write the angles or 

indices of the orientation directly into the text box visible in the toolbar. Users can see the 

value of the intensity for the selected orientation. The values of ODF or/and PF are displayed 

on the status bar (the sums PF value(s) or/and ODF value).  

 

Qualitative analysis is easy and straightforward to conduct. Users select the appropriate objects 

and then click 'SORT'. A window with assorted orientations from database by PF or ODF will 

appear. Users can also analyse the near (HKL)[UVW] orientations by clicking in the selected 

points on the pole figure or the ODF projection. "Near orientations" can be sorted by PF or 

ODF values, Miller indices or distance.  

 

 

1.11. Modelling of ODF, pole figures and inverse pole figures 
 

An ODF model can be easily created using LaboTex. 

In order to do that, user should select only:  

 Crystal Symmetry;  

 Sample Symmetry:  

 Grid cells for output ODF. 

 

Then one or more components (up to 10) should be selected. For each texture component users 

can choose:  

 volume fraction;  

 FWHM for each Euler angle (phi1, phi2 and phi);  

 distribution (Gauss or Lorentz). 

 

 

 

 

 

 

1.12. Quantitative Texture Analysis.  I - Volume fraction of texture 

components by integration methods (IM). 
 

LaboTex includes on-line quantitative analysis of a volume fraction of texture components. 
The volume fraction of each component, g, can be calculated by integrating over the 

appropriate subvolume in the orientation space [11] according to: 

   dggf
V

dv
)(

8

1
2

 

where  

 - dV / V is the volume fraction of grains with orientation g(),  

 - f(g) is the value of orientation distribution function, and dg = sinddd   

 are Euler angles that parameterize the orientation space.  

You can find more details in the LaboTex manual:  

“LaboTex: Modelling of ODF, Pole Figures and Inverse Pole Figure” available 

from our website www.labosoft.com.pl or www.labotex.com 

 

 

http://www.labosoft.com.pl/
http://www.labotex.com/
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The fundamentals for calculating a volume fraction of texture components are:  

o LaboTex makes the integration around the orientation in the ranges delta chosen by the user 

for each Euler angle:  

 1-1) to (1+1),  

 - to (+,  

 2-2) to (2+2),  

o In the case of exceeding the basic region of ODF space (Euler angles space) LaboTex 

continues the integration in the equivalent area of the basic region. 

 

The overlapping problem 

 

The overlapping problem appears when the integration ranges (delta) are too wide or when the 

orientations are closely situated in the Euler angles space. The integration area of texture 

components can be overlapped in two ways: 

i) by overlapping of the integration ranges between symmetrically equivalent positions of the 

component;  

ii) by overlapping of the integration ranges between the different components. 
 

 

LaboTex offers three different abilities (strategies) to solve the problem of overlapping of the 

integration ranges between symmetrically equivalent positions of component (case i):  
 

 "Simple Integration" – the overlapping region is multiple integrated. The integration around 

any single component in the full range of basic region gives (100%minus background)*number 

of a symmetrically equivalent position. 
 

 "Single Counts in Overlapping Area" - the overlapping region is only single integrated for 

the component. The integration around any single component in a full range of the basic region 

gives 100% minus background. 
 

 "Divide by Number of Symmetrically Equivalent Position" - LaboTex integrates for all 

symmetrically equivalent positions of the components with proper weight equal to 1/number of 

symmetrically equivalent positions. Integration around any single components in a full range of 

the basic region gives 100% minus background.  

 

To solve the problem of overlapping of integration ranges between different components in 

LaboTex (case ii) users can: 

 Adjust the total percent of overlapping (overlapping volume fraction) which is displayed in 

the Orientations Overlap" window. Overlapping volume fraction can be limited by diminishing 

integration ranges of texture components. 

1. In "Simple Integration" the overlapping volume fraction refers to the sum of overlapping 

between different components and between symmetrically equivalent positions of all 

overlapped components.  
 

2. In "Singlely Counts in Overlapping Area" the overlapping volume fraction refers to the sum 

overlapping between different components.  
 

3. In "Divide by Number of Symmetrically Equivalent Position" the overlapping volume 

fraction refers to the excessive orientation overlap. The excessive orientation overlap area is 

defined in the points where the sum of weights is greater than 1. The weight is equal to 

1/number of the symmetrically equivalent positions. The excessive ODF value in given point is 

equal to the product of the ODF value and sum of weights minus 1. The volume fraction of the 

excessive orientation overlap is the integral of excessive ODF values in the mentioned area.  
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 An overlapping volume fraction can be divided among overlapping orientations. This option 

causes the division of ODF values from overlap areas among overlapping orientations: 

1. In "Simple Integration" and "Singlely Counts in Overlapping Area" the ODF values in the 

overlapping areas are divided proportionally to the number of the symmetrically equivalent 

overlap orientations.  
 

2. In "Divide by Number of Symmetrically Equivalent Position" the excessive ODF values in 

the  overlapping areas are divided among components proportionally to the weights and to the 

number of symmetrically equivalent overlapping orientations.  

 

 

 

 

 

 

 

1.13. Quantitative  Texture Analysis.  II - Volume fraction of texture 

components by Model  Function Methods (MFM) 
 

LaboTex program includes a second method for determination of the volume fraction of texture 

components. Users can fit a model ODF (described in point 1.11.) to a real ODF and they select 

only the components (up to 10 components) and the distribution (Gauss or Lorentz). 

LaboTex fits:  

 volume fraction;  

 FWHM for each Euler angle (phi1, phi2 and phi);  

Users can also change the initial volume fraction and the FWHM parameters. 

Crystal symmetry, sample symmetry and grid cells for an output ODF are the same as for a real 

ODF.  

 

 

 

 

 

 

 

1.14. ODFs Comparison 

 
LaboTex offers three methods for comparison of ODFs: 

 ODF line sections (cuts) - users define two points in Euler Space. LaboTex shows ODF 

intensity along the section defined on the basis of these points. Users can also choose the 

initial points from the orientations database (by clicking the 'Start Point' or 'End Point' 

button). It is possible to compare up to 12 ODFs. 

 Skeleton lines - users can create a number of diagrams such as alpha-fiber, beta-fiber, 

gamma fiber etc. Users can choose the skeleton lines on the basis of the Euler angle (Phi1, 

Phi or Phi2) and:  

 maximal intensity; 

 integral intensity.  

Users can change the range in which LaboTex will look for the maximal ODF value or will 

conduct the integration (from +/-2 to +/-20 deg). Users can make comparisons of up to 12 

skeleton lines. 

 Misorientation histograms. Users define the starting point in Euler Space from which 

LaboTex will show the misorientation diagrams. Misorientations diagrams are calculated 

on the basis of ODFs within the range from 0 to 80 degrees counting from the starting point 

You can find more details in the LaboTex manual:  

“Determination of Volume Fraction of Texture Components  

Using LaboTex - Integration Method”  

Available from our websites: www.labosoft.com.pl or www.labotex.com 

 

 

You can find more details in the LaboTex manual:  

“Determination of Volume Fraction of Texture Components  

Using LaboTex - Model Functions Method” 

Available from our websites: www.labosoft.com.pl or www.labotex.com 

 

 

http://www.labosoft.com.pl/
http://www.labotex.com/
http://www.labosoft.com.pl/
http://www.labotex.com/
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(the starting orientation). LaboTex shows the intensity which is the relative intensity, that is 

the intensity which relates to the intensity of a random sample (I=I(sample)/I(random 

sample)) for the same range of the misorientation angle. Users can make comparisons of up 

to 12 misorientations histograms. Users can change the histogram step within the range 

from 1 to 10 degrees. 

 

 

1.15. ODF Transformation  

LaboTex calculates a new ODF which is a result of transformation of the initial ODF. The new 

ODF is created in a new job for sample of initial ODF. There are two kinds of transformations:  

o Frame rotations - users can rotate a sample frame along any Euler angle. This option is 

very important to see the ODF for other (different) sample position (for example, to see the 

ODF for the perpendicular surface with relation to the surface which was measured, you 

should transform the initial ODF by Phi=90deg). Users can create a changed sample 

symmetry for a new ODF.  

 

o Model rotations builder - (crystalites/planes rotations) firstly, users should build a rotation 

model and save it.  Secondly, you can choose up to 10 orientations of the rotation model for 

which you set:  

 the ranges of Euler angle around the center of the orientation (and for the 

symmetrically equivalent positions);  

 the vector "hkl" around which crystalites/planes will be rotated (only these 

crystalites/planes which are included in the chosen ranges);  

 the rotation angle;  

 the recent of the rotated crystalites/planes (from 0 to 100%).  

Finally, users choose the rotation model and conduct the ODF transformation. 

 

1.16. ODFs - logical operations   

Logical operations are conducted on the basis of two ODFs. LaboTex creates a new ODF 

which is one of:  

 an intersection of ODF A and ODF B,  

 a difference of ODF A and ODF B (or B-A),  

 a union of ODF A and ODF B,  

 a sum of ODF A and ODF B,  

 an ODF difference : A or B - an intersection A and B,  

 an inverted ODF (only for A).  

 

1.17.  2D and 3D Graphics 

 
The program includes an on-screen graphic presentation of calculated ODFs, PFs and INVs in 

a form of contour levels (isolines) shown in 2D and 3D spaces. 3D objects plotted on the screen 

can be increased, decreased, shifted, rotated and animated.  Up to 100 PFs or INVs can be 

presented in one window. In Compare Mode the objects of the same kind (PFs vs PFs, or INVs 

vs INVs, or ODFs vs ODFs) or of different kinds (PFs vs ODFs, PFs vs INVs, INVs vs ODFs) 

can be shown in two separated windows. Users can use pole figures cuts.  
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In order to do that, define the starting and end points on the pole figure and Labotex will show 

you the intensity along the selected section.  The following cuts are available:  

o 'Arc' (in the range from 0 to 360 degrees);  

o 'Radial' (in the range from 0 to 90 degrees);  

o 'Radial (full)' (in the range 90 - 0 - 90 degrees).  

 

Users can define a grid for the alpha angle and/or a grid for the beta angle of the PF. 

 

1.18.  Detailed Manuals  (www.labosoft.com.pl and www.labotex.com) 

 
You can find more details about LaboTex in our manuals: 

 

1)  Introduction to LaboTex 3.0 

2)  Menu Guide to LaboTex  

3)  Determination of Volume Fraction of Texture Components Using LaboTex - Integration 

Method  

4)  Determination of Volume Fraction of Texture Components Using LaboTex - Model 

Functions Method  

5)  Nomenclature of Inverse Pole Figures Use in LaboTex  

6)  Pole Figures: Registration and Plot Conventions  

7)  LaboTex: Modeling of ODF, Pole Figures and Inverse Pole Figure  

8)  Texture Analysis on the Base of the EBSD Data  

9) "Device-independent" pole figures for quantitative texture analysis (Techniques: PIM and IM) 

10) Fundamentals of 3-D Texture Analysis. Symmetry aspects of 3-D texture analysis 

11) Hexagonal Axes: Conventions & Conversions 

12) LaboTex – The Texture Analysis Software - Getting Started 

13) LaboTex: Modelling of ODF, Pole Figures and Inverse Pole Figure 

14) LaboTex: Skeleton Lines and Misorientation Diagrams 

 

All manuals are available on our websites www.labosoft.com.pl and www.labotex.com  

http://www.labosoft.com.pl/
http://labotex.com/
http://www.labosoft.com.pl/
http://www.labotex.com/
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1.19.  ADC method: Opinions and Applications                                                
 

 

 "... The strong and weak points of each method are examined showing that the 

iterative discrete methods (ADC and WIMV) are better suited for the 

reproduction of the texture function in the present case. In comparing these two 

discrete methods, it is evidenced that the ADC method reproduces more accurately 

both the experimental and synthetic texture functions over the entire range of 

texture sharpness considered ..." F.Caleyo, T.Baudin, M.H.Mathon and R.Penelle - 

Comparison of several methods for the reproduction of the orientation distribution 

function from pole figures in medium to strong textured materials - Eur. Phys. J. AP 15 

(2001), p85-96. 

 

 "... A discrete method (called as the Arbitrarily Defined Cells method) was applied 

to calculate the ODF. The 3-D distribution of orientations of the cellulose 

crystalline areas was reconstructed in the space of the Euler angles. Additionally, 

the complete pole figures as well as the inverse ones were recalculated. The 

presented analysis of the cellulose texture provides more extensive information on 

the space organisation of microfibrils than the standard methods...", Olek W., 

Pawlik K., Bonarski J. (2000): Space orientation of the crystalline areas of cellulose. 

Proceedings of the International Conference on Wood and Wood Fiber Composites, 13-

15 April 2000, Stuttgart, Germany: 37-46.  

 

 "... Direct Methods (WIMV, ADC) With 1 Degree Resolution Are Preferred...", 
K.J.Kozaczek,D.S.Kurtz, Quantitative texture analysis of blanket films and 

interconnects, Workshop on Texture in Electronic Applications NIST, Gaithersburg, 

MD, October 10-11, 2000.  
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  2. Getting started 

 

2.1. System Requirements 
 

LaboTex runs on MS Windows OS 7,8 or 10 platforms. 

 
 

1.2 Minimal hardware requirements 
 

Computer PC,  Processor PENTIUM IV (or compatible) 2 GHz,  512 MB RAM, 1 GB HD space, 

graphic card - resolution 1024x768, USB port. 

 

To use the full version of LaboTex, you need to install the protection key (you will need a USB port to 

do this).   
 

1.3 Recommended hardware requirements 
 

Processor Intel Core 2 Duo or Athlon 64 X2 or higher, 10 GB HD space, 4 GB RAM, graphic card 

resolution 1920x1080, USB port, color laser jet or inkjet printer.    

If your data are measured in the grid less than 5x5 degrees, double free disk space (20 GB)  is 

recommended. 

 

 

2.2. Installation 
 

To install LaboTex: 
 

1.    Switch off the computer. 

2.    Insert the USB Sentinel/HASP dongle (includes Protect Key & Electronic Media) to 

USB port. 

3.    Switch the computer on. 

       You have to have Administrator credentials to complete the installation 

procedure!  
4. Select drive assigned to USB dongle drive (using Windows Explorer on My Computer 

icon).  

Execute Setup.exe file and click OK.   

5.    You will see the ‘Welcome’ screen,  click Next. The Software License Agreement 

will be displayed. 

6.    Read the Software License Agreement and click Next to accept it. 

7.    Specify a directory to install LaboTex (we strongly recommend that you install 

LaboTex in the   

       default directory to avoid further possible conflicts) and click Next. 

8.    Enter the data for the main user, institution and serial number. The serial number 

can be found on the      dongle and in the License Agreement.      

1. Double check if all settings are correct and click Next. If you need to change any of the 

settings, click the Back button. 

10.  Now LaboTex is installed and you are prompted whether or not you want to view the 

README file.  To proceed further click Yes. 

11.  In order to install protect key driver (Sentinel/HASP) from the LaboSoft folder 

run "HASP Protect Key Installation" (double click the “HASP Protect Key 

Installation" file). 
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If you experience any problems during the installation process, please contact us via email 

office@labosoft.com.pl 

 

2.3. Configuration 

 
The first time you run LaboTex, you will need to configure a few options to your further optimize work:  

1) From the main menu select ‘Edit’> 'LaboTex Options...' 

2)   In the Tab Miscellaneous check if the following directories point to the right space on your hard 

drive: 

     A) Temporary Directory 

     B) Experimental Data Directory (EPF and other) 

     C) Correction Data Directory (COR 
You may change the default setup of the directories by clicking the ‘New’ button. 

mailto:office@labosoft.com.pl
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3. LaboTex Objects and Object Containers    

                 

3.1 Introduction 
 

Pole figures and orientations distribution functions (ODF) are LaboTex objects. Figure 3 shows 

a diagram for creating objects, calculation and analyses in LaboTex. 

Labotex operates  six types of objects: 

 

No Denotation Object Types 

1 CPF Corrected Pole Figures 

2 NPF Normalized Pole Figures 

3 RPF Recalculated Pole Figures 

4 APF Additional Pole Figures 

5 INV INVerse Pole figures 

6 ODF Orientation Distribution Function 

 

 

These six types of objects can be stored in three types of containers: Pole Figures Container, 

Inverse Pole Figures Container and Orientation Distribution Function container : 

   

No Container Objects Color 

1 Pole Figures Container CPF, NPF, RPF, APF yellow color 

2 Inverse Pole Figures Container INV blue color 

3 Orientation Distribution Function 

container 

ODF green color 

 

Objects from one container can be only shown in a single window at a time. Objects from two 

containers can be shown simultaneously only in the comparison mode (double windows - see: 

Compare Window Mode). To add or delete an object from a container click the relevant button 

on the object toolbar:   

 

Button Objects 

HKL CPF,NPF,RPF,APF 

XYZ INV 

Projection ODF 

 

The number of objects in containers is shown in the left bottom corner of the window (yellow 

for the pole figures container, blue for the inverse pole figures and green for the orientation 

distribution function container). There can only be one projection in the container of the ODF 

objects at a given time. For the ODF container the number of objects indicates the number of 2-

D ODF sections.  
 

The figure below shows an example when the Pole Figures Container contains 1 pole figure, 

the Inverse Pole Figures Container is empty (0 INV object) and the Orientation Distribution 

Function container contains a ODF projection which has 19 2-D ODF sections 



 19 

POWDER POLE
FIGURES DATA

(User Format)

filename.EPF filename.POWfilename.POWfilename.COR

EXPERIMENTAL POLE
FIGURES DATA

(User Format)

CALCULATED
CORRECTION

DATA

CALCULATED
CORRECTION

DATA

ASCII
file

ASCII
file

ASCII
file

ASCII
file

Objects Creations, Calculations and Analysis  

in LaboTex Program

ASCII
file

ASCII
file

ASCII
file

ASCII
file

filename.PPFfilename.PPF

PRELIMINARY CORRECTION
OF EXPERIMENTAL DATA

(external to LaboTex)

PRELIMINARY CORRECTION
OF EXPERIMENTAL DATA

(external to LaboTex)

APF

CPF

NPF RPF

INV

ODF

ASCII
file

ASCII
filefilename.SOR

SINGLE  ORIENTATION
EXPERIMENTAL DATA

(User Format)

INV

CPF to ODF,NPF,RPF,INV Calculation

JOB: 1 - 9

Options : PF symmetrization, PF Rotation, PF Range, Iteration

ODF to ODF 
ODF Symme-
   trization

JOB: 1 - 9 JOB: 1 - 9

 SOR to ODF
(New Sample)

    Quantitative 
  Analysis

     (Volume Analysis)

Orientation  
Analysis

(Qualitative Analysis)

    ODF to APF 
    Calculation

    ODF to INV 
    Calculation

    Orientations Type DataBase 

Pole Figures Data

from formula

CPF Creation (New Sample)

C
or

re
ct

io
n

 O
ff

USER

Method 1 Method 2 Method 3 Method 4

- LaboTex object type

(100)(010)(001)

  Conversion to
LaboTex Format

  Conversion to
LaboTex Format

  Conversion to
LaboTex Format

  Conversion to
LaboTex Format

    Quantitative 
  Analysis

     (Integration Met.)

    Quantitative 
  Analysis

     (Model Fun. Meth.)

    ODF to SOR (file) 
    Calculation

   Components  
   Model  to ODF 

Transformations   
ODF to ODF  

Logical Function   
ODF x ODF to ODF  

    ODF  to   Mistorie-

    ntation Distr. Calc.

 
 

 

Figure 3 
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For the ODF objects only one projection   or   or  can be stored in a container at a 

given time. To add or delete objects from the containers, click the relevant button on the object 

toolbar (for the pole figures container and the inverse pole figures container). 

 

Container Objects Limitation 

HKL  CPF,NPF,RPF,APF  maximum up to 100 objects 

XYZ  INV  maximum up to 100 objects    

Projection  ODF Projection maximum up to 360 2D ODF sections 

 

All objects in the container have to be in the same crystal symmetry. Objects arrangement on 

the screen can be changed as a new default (in LaboTex Options  -> Edit Menu ) or temporarily 

for the current session in Edit Menu –> Arrangement. 

To delete all objects in containers use Edit Menu -> Clear All  or select the toolbar button     

 

3.2 LaboTex Objects Types 
 

Pole figures used in LaboTex are of three types from the point of view of normalization: 

     i  -  unnormalised : EPF  

            ii  - approximately normalised :   CPF 

            iii - precisely normalised:  NPF,  RPF,   and  APF 

Pole figures from the experiment EPF and CPF have usually different intensities from pole 

figures of type iii (NPF, RPF and APF). 

All comparisons between pole figures should be done inside pole figures of type iii. 

Quantitative analysis can be conducted using normalised pole figures. 

 

3.2.1 CPF - Corrected Pole Figures 

 

Experimental pole figures obtained from X-ray or neutron diffraction are unormalised i.e. 

measurement intensities depend on the type of the X-ray or neutron source, the type of the 

counter, the collimating system, the absorption properties of measured material and so on. 

Therefore experimental pole figures are not comparable between each other. Pole figures can 

be correctly normalized only during the ODF calculation process. 

 

Corrected Pole Figures (CPF) can be corrected (according to background and de-focussing) and 

only preliminary normalized to experimental pole figures prepared for the ODF calculation. 

CPF object should not be used for analysis. CPF objects contain single pole figures of the hkl 

type.  

To create CPF objects from your experimental files, select File->New Sample or click   on 

the toolbar. You can calculate ODFs after creating CPF objects and create other objects.  

To display CPF objects click the CPF button on the object toolbar, then click one or more 

buttons with the hkl indices: 

 

 

Note: CPF objects are the same for all jobs. 
 

3.2.2 NPF - Normalized Pole Figures 

 
Normalized Pole Figures are completely normalized (during the ODF calculation process) 

experimental pole figures. They are correctly normalized and they can be compared between 
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each other. They are created after the ODF calculation. To display an NPF object click the NPF 

button on the object toolbar and then click one or more buttons with the hkl indices: 

 

 

Note: If more than one job have been created, choose the relevant job using the job 

buttons (J1,J2 ..) on the object toolbar. 

 

 
3.2.3.  RPF - Recalculated Pole Figures 

 
Recalculated Pole Figures are calculated from ODFs, equivalent to those PFs used as data to 

ODF reproduction. They are complete pole figures. 

To display RPF objects click the RPF button object toolbar, then click one or more buttons 

with the hkl indices: 

 

 

Note: If more than one job have been created, choose the relevant job using the job 

buttons (J1,J2 ..) on the object toolbar. 

 

3.2.4.  APF - Additional Pole Figures 

 
Additional Pole Figures are calculated from the ODF pole figures of HKL types which were 

not used for ODF determination. APF objects contain a collection of single additional pole 

figures. To calculate additional pole figures (APF) select Calculation menu -> ODF to APF or 

click the button  from the toolbar. 

For displaying APF object click the APF button on the object toolbar, then click one or more 

buttons with the hkl indices: 

 

 

Note: If more than one job have been created, choose the relevant job using the job 

buttons (J1,J2 ..) on the object toolbar. 

 

3.2.5.  INV - INVerse pole figures 

 
INVerse pole figures are calculated from ODFs. An inverse pole figures object (INV object) 

contains a collection of single inverse pole figures of XYZ types. INV objects: (100),(010) and 

(001) are always created after the ODF calculation. To calculate other inverse pole figures 

(INV) select Calculation menu ->ODF to INV or click the button  on the toolbar. To display 

an INV object click the INV button on the object toolbar, then click one or more buttons with 

the XYZ indices: 

 

 

Note: If more than one job have been created, choose the relevant job using the job 

buttons (J1,J2 ..) on the object toolbar. 
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3.2.6.ODF - Orientation Distribution Function 

 
Orientation Distribution Function is calculated from experimental pole figures (CPF objects) 

by the ADC method or from sets of single orientations. To calculate ODF and create ODF 

objects open the Calculation menu ->CPF to ODF, NPF, RPF, INV , Calculation menu ->SOR 

to ODF or click the button  from the toolbar. The ODF objects are 2-D ODF projections: , 

 . To display an ODF object click ODF button on the object toolbar, then click the 

button with the ODF projection: 

 

 

Note: If more than one job have been created, choose the relevant job using the job 

buttons (J1,J2 ..) on the object toolbar. 

 

3.3. Example CPF, NPF, RPF objects 
 
In the example below: 

CPF – experimental {111} pole figure (incomplete pole figure).  

ODF - calculated for symmetrization : triclinic to orthorhombic. 

NPF – normalized {111} pole figure. 

RPF - recalculated from ODF {111} pole figure (complete pole figure). 

 

In the example below: 

CPF – experimental {111} pole figure (incomplete pole figure).  

ODF - calculated for symmetrization : triclinic to orthorhombic and rotation of PF(s)= -2.5 deg. 

NPF – normalized {111} pole figure. 

RPF -  recalculated from ODF {111} pole figure (complete pole figure). 
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Experimental pole figures - aluminium - pole figures: CPFs, NPFs, RPFs 

 

 

 

3.4. LaboTex Jobs 
 
When one calculation (job) is already running, selecting next calculations of ODFs from the 

same sample creates new jobs. If more than one job has been created, select the relevant job 

using the job buttons (J1,J2 ..) on the object toolbar. A new job is also created when the  ODF 

symmetrisation is launched 

 

Job buttons:   

 

Note: The maximal number of jobs is 9 
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4. LaboTex Formats 

 

4.1. EPF file format                  
*.EPF (Experimental Pole Figures) files refer to the raw experimental data and their background. In 

order to use the EPF files you will need a correction file: *.COR or *.POW 

The table below provides a detailed description of the *. EPF data format: 
 

Line No of data 
in line 

Description Type 

1 – 2  Arbitrary title Character 

3  Remarks for data in line 4  

4 1 Structure Code (symmetries after Schoenflies): 
1  - C1  (triclinic)   
2  - C2  (monoclinic) 
3  - D2  (orthorhombic) 
4  - C4  (tetragonal) 
5  - D4  (tetragonal) 
6  - T (cubic)  
7  - O (cubic) 
8  - C3  (trigonal) 
9  - D3  (trigonal) 
10 - C6 (hexagonal) 
11 - D6 (hexagonal) 

Integer 

4 2 Lattice constant, a (absolute or relative) Real 

4 3 Lattice constant, b (absolute or relative) Real 

4 4 Lattice constant, c (absolute or relative) Real 

4 5 Lattice angle,  in degrees Real 

4 6 Lattice angle,  in degrees Real 

4 7 Lattice angle,  in degrees Real 

5 1 Number of Pole Figures (including background PFs) (N) Integer 

6  Remarks for data in line 7 Character 

7 to 7+N 1 2 Bragg angle in degrees  Real 

7 to 7+N 2 s- beginning of polar angle in degrees Real 

7 to 7+N 3 e -  ending of polar angle in degrees Real 

7 to 7+N 4 step of polar angle in degrees. Permissible value: 1.0, 1.2, 1.25, 
1.5, 2.0, 2.5, 3.0, 3.75, 5.0, 6.0, 7.5, 10.0.* 

Real 

7 to 7+N 5 s- - beginning of azimutal angle in degrees  (0 or 2.5) Real 
Positive values for 
pole figures drawn 
clockwise or 
negative values for 
counter-clockwise 

7 to 7+N 6 e  - ending of azimutal angle in degrees Real 
Positive values for 
pole figures drawn 
clockwise or 
negative values for 
counter-clockwise 

7 to 7+N 7 step of azimutal angle in degrees . Permissible values: 1.0, 1.2, 
1.25, 1.5, 2.0, 2.5, 3.0, 3.75, 5.0, 6.0, 7.5, 10.0. for textured pole 
figures, and the same values or multiplicity of above-mentioned values 
for background PFs 

Real 
Positive values for 
pole figures drawn 
clockwise or 
negative values for 
counter-clockwise 

7 to 7+N 8 Index - must be 0 Real 

7 to 7+N 9 Index h of hkl pole figure Integer 

7 to 7+N 10 Index k of hkl pole figure Integer 

7 to 7+N 11 Index l of hkl pole figure Integer 

7 to 7+N 12 Type of Data (1-Pole Figure, 0-Background) Integer 

7+N+1  Blank line  

7+N+2 1 to 8 Data 1 to 8 (1st Pole Figure) Real 

7+N+3 1 to 8 Data 9 to 16 (1st Pole Figure) Real 

7+N+4 to end  
of data for 1st PF 

1 to 8 Data for 1st Pole Figure Real 

...  Blank line  (separates block of data)  

... 1 to 8 Data for 2nd pole figure Real 

...  Blank line (separates block of data)  

... 1 to 8 Data for the next PF (up to end followed by blank line) Real 

Please note: Real and integer input data must be separated by one or more space signs. 
*LaboTex version 2.1.006 and higher allows new grid cell  1.8x1.8,2.25x2.5,3.6x3.6,4.5x4.5 (exceptions: trigonal,hexagonal and 
crystal lattice symmetry) 
See the specifications below  for:     EPF Example,  COR file format , POW file format , PPF file format , SOR file format. 
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4.2. EPF Example 
 
Example of an experimental data file *.EPF - test.epf: 

 
line   1: Test of LaboTex program - ADC method for ODF calculation.  
line   2: Sample: FeSi,  pole figures:    200   110  112 
line   3: Structure Code      a         b        c        alfa      beta     gamma  
line   4:            7        1         1        1         90        90        90  
line   5: 6  number of Pole Figures 
line   6:  2theta   alf-s  alf-e   d-alf  bet-s  bet-e   d-bet   indx   H K L  P/B 
line   7:  45.250    0.0    85.0    5.0    0.0   355.0     5.0     0    2 0 0   1 
line   8:  52.050    0.0    85.0    5.0    0.0   355.0     5.0     0    1 1 0   1 
line   9:  77.450    0.0    85.0    5.0    0.0   355.0     5.0     0    1 1 2   1 
line  10:  48.500    0.0    85.0    5.0    0.0   270.0    90.0     0    2 0 0   0 
line  11:  70.000    0.0    85.0    5.0    0.0   270.0    90.0     0    1 1 0   0 
line  12:  80.000    0.0    85.0    5.0    0.0   270.0    90.0     0    1 1 2   0 
line  13: 
line  14:   172763.   172763.   172763.   172763.   172763.   172763.   172763.   172763. 
line  15:   172763.   172763.   172763.   172763.   172763.   172763.   172763.   172763. 
line  16:   172763.   172763.   172763.   172763.   172763.   172763.   172763.   172763. 
... (line 17-172) 
line 173:    12871.    15208.    15536.    13571.    10464.     7874.     6977.     7874. 
line 174:    10464.    13571.    15536.    15208.    12871.     9947.     7753.     6885. 
line 175:     7512.     9977.    15302.    23949.    32907.    36331.    32369.    25152. 
line 176: 
line 177:    12319.    12319.    12319.    12319.    12319.    12319.    12319.    12319. 
line 178:    12319.    12319.    12319.    12319.    12319.    12319.    12319.    12319. 
line 179:    12319.    12319.    12319.    12319.    12319.    12319.    12319.    12319. 
... (line 180-335) 
line 336:    11977.    13260.    15924.    19655.    23043.    23659.    22398.    23659. 
line 337:    23043.    19655.    15924.    13260.    11977.    12233.    14581.    19084. 
line 338:    24630.    30445.    36111.    40462.    38757.    30857.    21645.    15090. 
line 339: 
line 340:   142442.   142442.   142442.   142442.   142442.   142442.   142442.   142442. 
line 341:   142442.   142442.   142442.   142442.   142442.   142442.   142442.   142442. 
line 342:   142442.   142442.   142442.   142442.   142442.   142442.   142442.   142442. 
... (line 343-498) 
line 499:    19467.    17249.    16302.    15782.    15387.    15200.    15068.    15200. 
line 500:    15387.    15782.    16302.    17249.    19467.    22203.    22229.    18484. 
line 501:    13296.     9168.     7555.     7739.     8997.    11247.    13362.    14321. 
line 502:  
line 503:      830.      792.      679.      717.      830.      792.      679.      717. 
line 504:      822.      784.      672.      710.      814.      777.      666.      703. 
line 505:      806.      769.      659.      696.      798.      762.      653.      689. 
... (line 506-508) 
line 509:      519.      495.      424.      448.      441.      421.      361.      381. 
line 510:      362.      346.      296.      313.      287.      274.      235.      248. 
line 511:      220.      210.      180.      190.      164.      157.      134.      142. 
line 512:  
line 513:     2258.     2156.     1848.     1951.     2258.     2156.     1848.     1951. 
line 514:     2258.     2156.     1848.     1951.     2236.     2134.     1830.     1931. 
line 515:     2236.     2134.     1830.     1931.     2236.     2134.     1830.     1931. 
... (line 516-518) 
line 519:     1981.     1891.     1621.     1711.     1851.     1767.     1515.     1599. 
line 520:     1637.     1562.     1339.     1413.     1329.     1268.     1087.     1147. 
line 521:      922.      880.      754.      796.      330.      315.      270.      285. 
line 522:  
line 523:     9209.     8791.     7535.     7954.     9209.     8791.     7535.     7954. 
line 524:     9118.     8704.     7460.     7875.     9118.     8704.     7460.     7875. 
line 525:     9029.     8618.     7387.     7798.     8941.     8535.     7315.     7722. 
... (line 526-528) 
line 529:     7611.     7265.     6227.     6573.     6977.     6660.     5708.     6025. 
line 530:     5903.     5635.     4830.     5098.     4723.     4508.     3864.     4079. 
line 540:     3143.     3000.     2572.     2715.     1246.     1190.     1020.     1076. 

 

See the specifications below  for: EPF file format, COR file format , POW file format, PPF file format , SOR file format. 
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4.3. PPF file format  
 
*.PPF (Preliminary Corrected Pole FiguresK ) files refer to the experimental data after 

conducting the background and de-focussing effects corrections using external procedures (not 

conducted in LaboTex). 

 

The structure of a *.PPF file is identical to *.EPF and *.POW except for the data for the 

background of pole figures. 
 

See the specifications below  for: EPF file format, COR file format, POW file format , SOR file format . 

 
 

4.4. SOR file format  
 
*.SOR (Single Orientation) files refer to experimental, single orientation set in the LaboTex 

format  

The table below provides a detailed description of *.SOR data format: 

 
Line No of data 

in line 
Description Type 

1 - 2  Arbitrary title Character 

3  Remarks for data in line 4  

4 1 Structure Code (symmetries after Schoenflies): 
1  - C1  (triclinic)   
2  - C2  (monoclinic) 
3  - D2  (orthorhombic) 
4  - C4  (tetragonal) 
5  - D4  (tetragonal) 
6  - T (cubic)  
7  - O (cubic) 
8  - C3  (trigonal) 
9  - D3  (trigonal) 
10 - C6 (hexagonal) 
11 - D6 (hexagonal) 

Integer 

4 2 Lattice constant, a (absolute or relative) Real 

4 3 Lattice constant, b (absolute or relative) Real 

4 4 Lattice constant, c (absolute or relative) Real 

4 5 Lattice angle,  in degrees Real 

4 6 Lattice angle,  in degrees Real 

4 7 Lattice angle,  in degrees Real 

4 8 Step for output ODF (grid cells). Permissible values (deg): 
1.0, 1.2, 1.25, 1.5, 2.0, 2.5, 3.0, 3.75, 5.0, 6.0, 7.5, 10.0* 

Real 

4 9 Weight  for data (1 – present, 0 – absent) Integer 

4 10 Angle Unit: 0 – deg, 1 – rad Integer 

4 11 Angle Convention: 0 – Bunge 1 – Roe  Integer 

5 to the end 1 1 Real 

5 to the end 2  Real 

5 to the end 3 2 Real 

5 to the end [4]  Weight (optionally) (if parameter weight in line 4 is 1) Real 

Note: Real and integer input data must be separated in line by one or more spaces. 
*LaboTex allows new grid cell from version 21.006: 1.8x1.8,2.25x2.5,3.6x3.6,4.5x4.5 (exceptions: trigonal,hexagonal crystal 
lattice symmetry 

See the specifications below  for:  EPF file format, COR file format, POW file format , PPF file format. 

 

 

4.5. POW format 
 
*.POW ( POWder pole figures) files refer to the  powder sample pole figures measured, if 

possible, for a specific sample. 

You should measure the pole figures of the powder sample for defocusing correction from the 

same material as the "textured samples". The powder sample is treated as "non-texture" sample 

which helps to identify the absorption curve for defocusing correction. 

The structure of *. POW file is identical to *.EPF. 

  
See the specifications below for: EPF file format, COR file format, SOR file format , PPF file format.  
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4.6. COR format 
*.COR (CORrection) files refer to coefficients for the de-focussing effect. 

*.COR files contain a set of correction coefficients for the de-focussing effect.  

 

The table below provides a detailed description of *.COR data format: 

 
Line No of data 

in line 
Description Type 

1 – 2  Arbitrary title Character 

3 1 to n  in degrees (polar angle) Real 

4 1 {hkl} of first pole figure (three digits number) Real 

4 2 to n+1 correction coefficients for de-focussing effect Real 

5 1 {hkl} of second pole figure (three digits number) Real 

5 2 to n+1 correction coefficients for de-focussing effect Real 

...  ...  

3+N*2 1 {hkl} (three digits number)  N - number of pole figure Real 

4+N*2 2 to n+1 correction coefficients for de-focussing effect Real 

Please note: Real and integer input data must be separated by one or more space signs. 

See the specifications below  for : EPF file format, PPF file format, SOR file format, POW file format. 

 

4.7. Other data formats 
List of the compatible LaboTex data formats. 

 
All trademarks are the properties of their respective owners and are only used in a descriptive fashion without any 

intention to infringe. 

(For the updates and the current list of LaboTex compatible file formats see: www.labosoft.com.pl ) 

 

 'TSV' Single Orientations Files,  

o Single orientations data files: *.tsv can be selected from File->New Sample-> Choose 

Experimental Data  

 'PLF' Queens Univ. PF Format files (4*5deg) - (corrected pole figures),  

o Pole figures data files : *.plf can be selected from File->New Sample-> Choose 

Experimental Data   

 'PLF' 5*5deg - (corrected pole figures),  

o Pole figures data files : *.plf can be selected from File->New Sample-> Choose 

Experimental Data   

 'CON' McGill University PF Format files - (corrected pole figures),  

o Pole figures data files : *.con can be selected from File->New Sample-> Choose 

Experimental Data  

 'HKL' HKL - Kawasaki KTEC Format files - (corrected pole figures),  

o Pole figures data files : *-hkl. can be selected from File->New Sample-> Choose 

Experimental Data   

 'hkl' AGH main format,  

o Pole figures data files : *.hkl can be selected from File->New Sample-> Choose 

Experimental Data   

o Background pole figures data files: *-b.hkl can be selected from File->New Sample-> 

Choose Experimental Data  

http://www.labosoft.com.pl/
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o Random(powder) pole figures data files: *-p.hkl can be selected from File->New Sample-

> Choose Experimental Data  

o Background random(powder) pole figures data files: *-t.hkl can be selected from File-

>New Sample-> Choose Experimental Data   

 'xfb' AGH second format (corrected pole figures),  

o Pole figures data files : *.xfb can be selected from File->New Sample-> Choose 

Experimental Data   

 'CTF' HKL Single Orientations Files,  

o Single orientations data files: *.CTF can be selected from File->New Sample-> Choose 

Experimental Data   

 'SNG' TSL Single Orientations Files,  

o Single orientations data files: *.sng can be selected from File->New Sample-> Choose 

Experimental Data   

 'TXT' HKL Single Orientations Files,  

o Single orientations data files: *.txt can be selected from File->New Sample-> Choose 

Experimental Data   

 'UXD' (file version 1) -  SIEMENS/BRUKER (corrected pole figures, ASCII-

files!,GADDS/D-8 Discover XRD). Use only one pole figure in one file. Parameter 

"_sample" has to contain Miller indices of PF (in triangle brackets) for example: "Ir<111>".  

o Pole figures data files: *.uxd can be selected from File->New Sample-> Choose 

Experimental Data  

o Please note: Convert the binary files from the GADDS/D-8 Discover XRD to the the 

ASCII UXD files using software from Siemens/Bruker (XCH or other).  

 'UXD' (file version 2) - BRUKER (corrected pole figures, ASCII-file!,GADDS/D-8 

Discover XRD).  

o Pole figures data files: *.uxd  can be selected from File->New Sample-> Choose 

Experimental Data  

o Please note: Convert the binary files from the GADDS/D-8 Discover XRD to the ASCII 

UXD files using the software from Bruker (XCH or other).Use only one pole figure in one 

file. The parameter "_sample" has to contain Miller indices of PF (in triangle brackets), for 

example: "Ir<111>". 

LaboTex can read background files for the UXD format:  

1) mark the data for background with 'B' letter in indices of pole figure (for example, the 

filename should be '<111B>cu brut').  

----------------------------------------------------  

_FILEVERSION=2  

_SAMPLE="<111B> cu brut"  

_SITE='UNIV ...'  

_USER='LAMBDA'  

...  

------------------------------------------------  
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2) LaboTex requires one pole figure in one UXD file.  

Each pole figure and background file has to be in a separate file with the extension *.UXD.  

For example: sample_100.UXD, sample_100BL.UXD, sample_100BR.UXD, ...  

(the filenames which terminate with ‘BL’ or ‘BR’ include the background from the 'left' and 'right' 

side of PF. LaboTex average BL and BR values.)  

3)You may use only BL or BR file.  

4) Background files in the UXD format can have only one background value for one alpha value!  

For example, if you have one pole figure, Cu-brut_111.UXD, you should make 3 files in XRD 

software:  
a) Cu-brut_111.UXD (pole figure data+ parameter sample: _SAMPLE="<111> cu brut")  

b) Cu-brut_111BL.UXD (left background data + parameter sample: _SAMPLE="<111B> cu brut")  

c) Cu-brut_111BR.UXD (right background data+ parameter sample: _SAMPLE="<111B> cu brut")    

o Many pole figures in a file (2 cases). Please convert XCH (or any other format) to UXD with options: 

2Theta-Intensity and with one column of intensity values. You can input data for azimuthal (KHI) angle in 

ranges: 0.0-360.0,0.0-180.0,0.0-90.0 or 0.0-X degrees (where 0.0<X<=50.0) 

 enter manually the hkl indices in triangle brackets to the UXD file in places where the pole 

figure data starts (available from version 3.0.004)::  

-------------------------------------  

... (header) 

_ANODE='Cu' 

<111>  

; (Data for Range number 1) <--- start (data for first pole figure) 

_DRIVE='PHI' 

_STEPTIME=5.000000 

... 

<110>  

; (Data for Range number 17) <--- start (data for second pole figure)  

_DRIVE='PHI' 

_STEPTIME=5.000000 

... 

------------------------------------- 
For the background data add 'B' letter to the hkl indices (for example: <111B>). The background data in 

UXD format can have only one background value for one alpha/PHI value!  

You can also enter defocussing correction data (from version 3.0.004). 

Random (powder) pole figures data files: *.UXD can be selected  "Choose Defocussing Correction" list. 
 (available from version 3.0.006):  
enter manually the hkl indices in triangle brackets to the UXD file from the second line in the file. For 

the background data please add 'B' letter to the hkl indices (for example: <111B>).  

-------------------------------------  

;remarks line (first line) 

<111>  

<111B>  

<111B>  

<200>  

<200B>  

<200B>  

<311>  

<311B>  

<311B>  

_FILEVERSION=2  

_SAMPLE='Copper'  

... 

------------------------------------- 



 30 

Background data in UXD format can have only one background value for one alpha/PHI value!  

If your file contains background data with a label "_RATE_BKG=", LaboTex will 

automatically correct your pole figure. In such case do not enter the hkl indices for the 

background into your file. You can enter the defocussing correction data in the same way. 

Random (powder) pole figures data files: *.  can be selected from File->New Sample-> Choose 

Defocussing Correction.  

 'UXD' As 'UXD' formats above (SIEMENS/BRUKER file version 1 and 2) - only with 

reversed radial direction! Corrected pole figures (ASCII-files).  

 'HKL' Chalk River Neutron Diffr. Data (corrected pole figures)  

o Pole figures data files: *.* can be selected from File->New Sample-> Choose 

Experimental Data  

 'ANA' - EMSE Format files (corrected pole figures)  

o Pole figures data files: *.ana can be selected from File->New Sample-> Choose 

Experimental Data  

 'epf' - popLA PF Format files (corrected pole figures).  

Please note: Files in popLA format have the same extension as LaboTex files: "EPF". 

Select "epf" (small capitals!) data format in LaboTex Options for files in popLA format.  

o Pole figures data files: *.epf can be selected from File->New Sample-> Choose 

Experimental Data  

 'RAW' - popLA Format files  

o Pole figures data files: *.raw can be selected from File->New Sample-> Choose 

Experimental Data   

o Defocussing correction data files: *.dfb can be selected from File->New Sample-> 

Choose Defocussing Correction  

 'ASC' - Rigaku ASC format (1PF/file)  

o Pole figures data files: *.asc can be selected from File->New Sample-> Choose 

Experimental Data   

o Random(powder) pole figures data files: *.asc can be selected from File->New Sample-> 

Choose Defocussing Correction 

 'XPF' - BEARTEX data format (corrected pole figures)  

o Pole figures data files: *.xpf can be selected from File->New Sample-> Choose 

Experimental Data   

 'PFG' - RIST data format from RIGAKU (ASCII)  

o Pole figures data files: *.pfg can be selected from File->New Sample-> Choose 

Experimental Data   

o Random pole figures data files: *.pfg can be selected from File->New Sample-> Choose 

Defocussing Correction  

 'TXT' - RIST data format from PHILIPS (ASCII- corrected pole figures)  

o Pole figures data files: *.txt can be selected from File->New Sample-> Choose 

Experimental Data    
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 'RW1' - PHILIPS X'Pert binary data format (Binary)  

o Pole figures data files: *.rw1 can be selected from File->New Sample-> Choose 

Experimental Data  

o Background pole figures data files: *.bgr can be selected from File->New Sample-> 

Choose Experimental Data   

o Defocussing correction data files: *.cor can be selected from File->New Sample-> 

Choose Defocussing Correction 

Please note: Background pole figures data files may have the same extension as defocussing 

correction data files ('COR'). Please change 'COR' extension for the background files to 'BGR'! 

 'NJA' - Seifert ASCII data format (compatible also with data from PSD) 

o Pole figures data files: *.NJA can be selected from File->New Sample-> Choose 

Experimental Data   

o Random pole figures data files: *.NJA can be selected from File->New Sample-> Choose 

Defocussing Correction 

 ‘NJC’ - Seifert binary data format (compatible also with data from PSD)  

o Pole figures data files: *.NJC can be selected from File->New Sample-> Choose 

Experimental Data   

o Random pole figures data files: *.NJC can be selected from File->New Sample-> Choose 

Defocussing Correction  

 'DAT' - Seifert ISO-DEBYFLEX 3003 - ASCII data format. Use only one pole figure in 

one file. Pole figure indices are 3 last characters before the period in the filename 

(example: PC_200.DAT for 200 pole figure). Optionally you may add the parameter 

"2THETA" before label "XDATA" in the file (for example 2THETA=33.45). Values of 

2THETA are essential for defocussing correction from Schultz equation. You may also use 

non equal angle step: 5deg for inclination angle (chi or alpha) and 10 deg for the azimuthal 

angle (phi or betha) - data are approximated to 5x5 grid. Background data (one data for 

each value of inclination angle) are first after the label "XDATA".  

o Pole figures data files: *.DAT can be selected from File->New Sample-> Choose 

Experimental Data   

o Random pole figures data files: *.DAT can be selected from File->New Sample-> Choose 

Defocussing Correction  

 'COA' COA data format (corrected pole figures).  

 'POL' - The University of Birmingham/HiltonBrooks Texture Data.  

o Pole figures data files: *.POL can be selected from File->New Sample-> Choose 

Experimental Data  

o Random pole figures data files: *.POL can be selected from File->New Sample-> Choose 

Defocussing Correction  

 'DAT' - TU Berlin data format (1PF/file)  

o Pole figures data files: *.DAT can be selected from File->New Sample-> Choose 

Experimental Data   
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 'POL' - The University of Birmingham with background (add '_b' to filename for 

background data).  

o Pole figures data files: *.POL can be selected from File->New Sample-> Choose 

Experimental Data   

o Background data for pole figures (filename_b.pol): *.POL can be selected from File-

>New Sample-> Choose Experimental Data  

o Random pole figures data files: *.POL can be selected from File->New Sample-> Choose 

Defocussing Correction 

o Background data for random pole figures (filename_b.pol): *.POL can be selected from 

File->New Sample-> Choose Defocussing Correction  

 '000' - U.Paris-Sud (Neutron Diffr.Data) (1PF/file) (add '_b' to filename for background 

data)  

o Pole figures data files: *.DAT can be selected from File->New Sample-> Choose 

Experimental Data   

o Background data for pole figures (filename_b.000): *.DAT can be selected from File-

>New Sample-> Choose Experimental Data  

 'RWA' - Philips ATC3 (add '_b' to filename for background data)  

o Pole figures data files: *.RWA can be selected from File->New Sample-> Choose 

Experimental Data   

o Background data for pole figures (filename_b.RWA): *.RWA can be selected from File-

>New Sample-> Choose Experimental Data  

o Random pole figures data files: *.RWA can be selected from File->New Sample-> 

Choose Defocussing Correction  

o Background data for random pole figures (filename_b.RWA): *.RWA can be selected 

from File->New Sample-> Choose Defocussing Correction 

 'M ' - University of Northeastern (Shenyang) (add '_b' to filename for background data)  

o Pole figures data files: *.M can be selected from File->New Sample-> Choose 

Experimental Data   

o Background data for pole figures (filename_b.M): *.M can be selected from File->New 

Sample-> Choose Experimental Data   

o Random pole figures data files: *.M can be selected from File->New Sample-> Choose 

Defocussing Correction  

o Background data for random pole figures (filename_b.M): *.M can be selected from File-

>New Sample-> Choose Defocussing Correction  

  'EXP' (also 'CAL' and 'COR') (add '_b' to filename for background data) - Experimental 

data - RWTH Achen  

('CAL' - recalculated pole figures and 'COR' - corrected pole figures can be also used.)  

o Pole figures data files: *.EXP (or *CAL or *COR) can be selected from File->New 

Sample-> Choose Experimental Data;   
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o Background data for pole figures (filename_b.EXP,) can be selected from File->New 

Sample-> Choose Experimental Data ;  

o Random pole figures data files: *.EXP can be selected from File->New Sample-> Choose 

Defocussing Correction  

o Background data for random pole figures (filename_b.EXP) can be selected from File-

>New Sample-> Choose Defocussing Correction  

 'HPF' (add '_b' to filename for background data) - Experimental data - pole figures   

o Pole figures data files: *.HPF can be selected from File->New Sample-> Choose 

Experimental Data;   

o Background data for pole figures (filename_b.HPF) can be selected from File->New 

Sample-> Choose Experimental Data;  

o Random pole figures data files: *.HPF can be selected from File->New Sample-> Choose 

Defocussing Correction  

o Background data for random pole figures (filename_b.HPF) can be selected from File-

>New Sample-> Choose Defocussing Correction 

4.8. How make given format accessible for LaboTex 
 
To enter experimental or modeling data to LaboTex select File> New Sample. You can change the data 

formats  using the radio buttons in the top of the New Sample window (see below). If  your data format 

is not listed (for example like on the screenshot below it is not “EPF”, PPF”, ”SOR”, ”TSV”, ”PLF”, 

”CON”, ”HKL”),  you can select your data format from Edit>LaboTex Options>Data Formats tab (see 

below for the detailed instructions).  

LaboTex allows a maximum of 7 active data formats in the New Sample window. The formats EPF, 

PPF and SOR are the default fixed active formats. You can choose up to 4 more active data formats 

(non-LaboTex). LaboTex allows you to choose from 36 different data formats. 

  

 
  
  
  
  
 

 

 

 

 

 

 

 

 

 
 

 

To select the active data formats for the window New Sample for creation of CPF files: 

a) from the main menu select Edit>LaboTex Options 
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b) in the window LaboTex-Options select the tab Data Formats  

c) the first three formats (EPF, PPF, SOR) are preselected and fixed out but you can change 

formats 4 to 7 using the drop down list (see the screenshot below). 

 

 
 

 

 

 

 

For example, to make format PFG (Rigaku ASCII or binary data format) accessible for creation of 

CPF:  

a) from the main menu select Edit>LaboTex Options… 

b) in the window LaboTex-Options select the tab Data Formats 

c) from one of the drop down lists (from 4 to 7) select 'PFG' - RIST data format 3014 (see the following 

screenshot).  
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You can change the default parameters for data format using relevant the checkboxes or radio buttons. 

 

Now when you open the New Sample window (File>New Sample), you will see the “PFG” file format 

listed.  

 

 
 

To simultaneously use several files with the data from the same sample :  

 select the relevant files in the files selection box by holding the Ctrl key on your keyboard and 

left-clicking the filenames with your mouse. The selected files will be highlighted in blue (see 

the screenshot below). 
 

If you have files with corrected pole figures, select these files  from the file list in the New Sample 

window  ("Choose Experimental Data"). 
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If you have files with non-corrected pole figures and files with data for defocussing and background 

correction, set the extension for all these files to PFG (*.pfg). The files with the background correction 

data should also have  “_B” in their filename before file extension “.PFG” (for example: 

ferrite_B.PFG). Once you adjusted all file extensions, you can select the data from the lists in the 'New 

Sample' window: 

 Pole figures - data files: *.pfg (from the "Choose Experimental Data" list)  

 Background of pole figures - data files: *_B.pfg ( from the "Choose Experimental Data" 

list)  

 Defocussing correction data files (files with  pole figures from a ‘random’ (powder) 

sample): *.pfg (from the "Choose Defocussing Correction" list)  

 Background of pole figures with defocussing correction data - files: *_B.pfg (from the 

"Choose Defocussing Correction" list) 

 
 

 

For more details see 'Pole Figures: Plot and Registration Conventions' PDF file on www.labosoft.com.pl 

or www.latotex.com  

  
Please note:  
LaboTex can input data for different azimuthal and radial steps (azimuthal step is adjusted to radial step 

by linear interpolation).  

Azimuthal step has to be within the range 1-10 deg., one of radial steps from: 1., 2., 1.2, 1.25, 1.5, 2., 

2.5, 3., 3.75, 5., 6., 7.5, 10. degrees and extra: 1.8 ,2.25 ,3.6 ,4.5 except from trigonal and hexagonal 

crystal lattice symmetry.  

The radial step for defocussing correction data has to be the same as for the pole figures(!). 
  

 

 

http://www.labosoft.com.pl/
http://www.latotex.com/
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To make format accessible for creation of CPF files:  
a) select Edit->LaboTex Options;  

b) select the Data Formats tab; 

c) select the names of desired format from the drop down menus 4 -7.  

 
To simultaneously use several files with the data from the same sample :  

 select the relevant files in the files selection box by holding the Ctrl key on your keyboard and 

left-clicking the filenames with your mouse. The selected files will be highlighted in blue (see 

the screenshot below). 

 

If the extensions of your data files differ from those available, please to change them: for 

example, (in RW1 format) background pole figures data files have the *.COR extension by 

default. This extension is the same as for defocussing correction data files. Change the 

extension of the background pole figures data files to *.BGR before entering them to LaboTex. 

 

 

All trademarks are the properties of their respective owners and are only used in a descriptive 

fashion without any intention to infringe.  
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5. LaboTex - Frequently Asked Questions (FAQ)  

 

Q: In the LaboTex demo version the raw data for the pole figure contains the data from 0 

to 90 deg alpha angle tilt. In our pole figure the data obtained by the reflection method 

ranges from 0 to 75 deg as at the higher angles the beam is parallel to the sample surface 

leading to defocussing. Is the incomplete pole figure data obtained by us using the back 

reflection method enough to conduct analysis? 

A: Yes, you can use incomplete pole figures for analysis. LaboTex accepts pole distances 

smaller than 90 deg. It can be 85, 80, 75 deg. and so on. You can cut off the pole figure in the 

center as well and start the pole distance not from 0 deg. but from 5, 10, 15.... deg. (for the 

transmision technique). 

 

Q: At each alpha tilt angle we get the background values. There is no information in the 

software how to do the background correction by using these values. Also the raw data 

does not give the background values. 

A: In the demo version we have not used the background values. However, if you check the 

structure of an EPF file (see HELP menu), you will see that LaboTex accepts the background 

data. 

 

Q: We need to do the ODF for the HCP metals like Titanium, Zirconium and some cubic 

metals like steel. We may not need the other crystal geometry. 

A: LaboTex calculates ODF for all crystal symmetries. You can use whichever you wish. 

 

Q: The maximum intensity value of PF data which is obtained by X-ray machine is 

different from the one appearing on the computer screen of LABOTEX PF analysis. Any 

reason? 

A: Experimental pole figures obtained from X-ray diffraction are unnormalized. The measured 

intensities depend on the type of the X-ray source, the type of a counter, the colimating system, 

the absorption properties of measured material and so on. Therefore the pole figures from an X-

ray machine are not comparable between each other. Pole figures can be normalised in the 

ODF calculation process. 

Pole figures used in LaboTex program are of two types: 

I - approximately normalysed : .CPF 

II - precisely normalysed: .NPF, .RPF, and .APF 

Pole figures and the maximum intensities from X-ray and  .EPF and .CPF usually have 

different intensities than pole figures of type II (.NPF, .RPF, and .APF). All comparisons 

between pole figures should be done inside the pole figures of type II!  Quantitative analysis 

can be made using only normalyzed pole figures! 
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Q: Does the accuracy or the reliability of PF-to-ODF conversion depend on the type of the 

feature of the textures concerned? For example, is there any difference in the accuracy 

between Goss and cube oriented textures? 

A: No, the accuracy of different texture components does not depend on the type of texture 

component in calculation by the ADC method in LaboTex. 

 

Q: Is the algorithm for calculation of ODF's different from the 'WIMV' algorithm in the 

POPLA package?  

A: The algorithm used in LaboTex is different from the WIMV method. LaboTex implements 

the original ADC algorithm.   

There are some similarities between WIMV and ADC methods: 

1) both methods belong to the same group of so called direct methods (or discrete methods) in 

opposition to Fourier series methods; 

2) both methods use iteration procedures. 

The main differences between ADC and WIMV methods: 

1) different principles of the iteration procedure; 

2) different principles of "ghosts" correction. 

 

For more details see:  

H.-R. Wenk, K. Pawlik, J. Pospiech and J.S. Kallend (1994) Deconvolution of superposed pole 

figures by discrete ODF methods: Comparison of ADC and WIMV for quartz and calcite with 

trigonal crystal and triclinic specimen symmetry. Textures and Microstructures 22, 233-260. 

 

U. F. Kocks, C. N. Tomi, H. R. Wenk, "Texture and Anisotropy", Cambridge University Press  

 

F.Caleyo, T.Baudin, M.H.Mathon and R.Penelle, Comparison of several methods for the 

reproduction of the orientation distribution function from pole figures in medium to strong 

textured materials - Eur. Phys. J. AP 15 (2001), p85-96  

 ("... The strong and weak points of each method are examined showing that the iterative 

discrete methods (ADC and WIMV) are better suited for the reproduction of the texture 

function in the present case. In comparing these two discrete methods, it is evidenced that the 

ADC method reproduces more accurately both the experimental and synthetic texture functions 

over the entire range of texture sharpness considered ...") 

 

There are more papers describing the principles of the ADC method. For the references see the 

ADC Method section on our website www.labosoft.com.pl  

 

Q: I am looking for a better reference or way to index ODF patterns. Mostly, I use figures 

from Bunge's book which show low index orientations. Working with steel, I come across 

many higher order reflections like {554}<225> and I can calculate these angles if I know 

what to look for, but it’s very tedious to  index some higher order reflections by guessing 

what they might be and then  calculating the angles- checking, guessing again, 

calculating... I would like a program which takes Euler angles from the input and lists the 

closest {hkl}<uvw>  indices. I guess I'll program something like this unless anyone can 

suggest a better method or point me towards something that has already been written. 

A: Your problem of indexing ODF patterns can be solved using LaboTex. LaboTex is 

performing texture analysis using pole figures and ODF. LaboTex can do it simultaneously! 

 

http://www.labosoft.com.pl/
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Q: What indices I should use for hexagonal symmetry? 

A: In case of hexagonal symmetry you should transform {hkil} -> {hkl} by excluding {i} 

indices. For example: {01-11} to {011};  

For pole figures, if the first or second index is negative, please rearrange it so that the first  

two indices are positive and exclude the third index (which is the negative sum of the first two). 

The last index remains the same.  

For example: {-2110} to {11-20} and final {110};  

For crystal directions < uvtw > ==> < UVW > please calculate:  

U=u-t  

V=v-t  

W=w  

For example: <11-20> to <330> and final <110>;  

Please, check this for calculate orientation {0,1,-1,1} <2,-1,-1,0>:  

{0,1,-1,1} <2,-1,-1,0> ==> {0,1,1}<1,0,0>  

 

Q: The format of the raw data as we get it is different than the one used by you. How do 

you propose to change the data structure so that it can be suitable for the software? 

A: If format your data is not available in LaboTex (see: Edit -> LaboTex Options -> Data 

Formats), we have two suggestions: 

1) Take a look at the description of data file structure in the LaboTex Demo HELP menu. 

Check the "LaboTex Format  of Experimental Data" option and the examples of *.EPF , 

*.COR and *.POW. Then you can transform your data to EPF and COR type format. 

2) You can send us examples of your data files and the LaboSoft team will prepare the 

LaboTex input to accept your data format, free of charge for our customers. 

 

 

 

 

 

 

Q: Can I create a CPF file myself?  We would like to calculate an ODF with pole figures 

which have been multiplied by corrected factors and which were not re-normalised after 

this multiplication. 

A: .CPF files are binary files with a complicated structure. We can suggest two solutions: 

1) You can save your special data as a 'PPF' file (for more details how to see Help section). 

This file does not include background data and you do not need to use .COR file. 

2) You can save your special pole figures as 'EPF' file including the proper number of "0" 

values for the background for each pole figure at the end of the file. Remember to add the lines 

describing your data (at the beginning of the file) for each pole figure background. In such 

cases, you need to make a 'COR' file which includes correction coefficients equal to "1". 
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Q: What should I do to read Rigaku data?  

A: For Rigaku data files, remember to use only one pole figure per file and to set the extension 

of your files to *.ASC (for example: 53110.ASC, 53200.ASC, 53211.ASC).  

To make the *.ASC files accessible in LaboTex for creation of CPF files:  

a) select Edit->LaboTex Options;  

b) select the Data Formats tab; 

c)  select "ASC - Rigaku ASC format (1PF/file)" one of the from the drop down lists 4 -7; 

d)  select File -> New sample  then select "ASC" data format. If you do not use defocusing 

correction, select "off" for "Correction”; 

e)  select ASC pole figures files; 

f)  select the proper crystal symmetry for your sample. 

 

 

Q: Could you please tell me whether LaboTex for Windows could be used for files 

generated with Bruker equipment?  

A: Yes. UXD file version 1 and 2 and the UXD data format with reversed radial angle direction 

are all compatible with LaboTex. For more details see www.labotex.com/format.htm   

 

Q: When using ASC format only one PF file can be included and other APF can be 

calculated by the software. Does that mean that it is not necessary to measure other PFs 

experimentally? Can I include other PFs such as 200 and 112 apart from 110 in the BCC 

structure? On the other hand, in the EPF format several PFs can be input simultaneously. 

How about the difference in the EPF and ASC cases?  

A: It is possible use more PFs (files). You may use 110, 200 and 112 PFs simultaneously. In 

File->New Sample window select (by a mouse click) several ASC files simultaneously by 

holding the CTRL (control) key. Calculating the ODF from one PF is not always enough. In 

such cases, you should use more PFs.  

 

Q: Is there any simple way to transfer ASC format into EPF format with 8 columns?  

A: When you create a CPF file from an ASC file, LaboTex will convert ASC files to the 

EPF/POW or PPF files. You can then find these files in the LaboTex temporary directory (for 

example: C:\Labotex2\user\username.LAB\tmp...).  

 

Q: As for the background data, I cannot find a way to input that to the file when an ASC 

has been included. Can the background data only be used in the EPF format?  

A: Usually the measured pole figures must be corrected according to the background and the 

defocusing absorption. You should measure these values for your samples. These both 

corrections of the raw pole figures data are sometimes done by the software used with the 

experimental X-ray device (especially if you use PSD-Position Sensitive Detector). You should 

check whether this can be done with your x-ray device (i.e. whether it is a type of a PSD 

detector). Inside the ASC file format you can find two places in which the background values 

can be included. Find the lines with words: *LOW, *HIGH. Your files will have zero values in 

these places. You should decide whether this is the correct value. If it is not, consult the manual 

for your X-ray device to find how to measure and include the background values to your ASC 

files in positions *LOW and *HIGH inside the files.  

 

http://www.labotex.com/format.htm
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Q: I am studying the texture in steel. Which correction file and the symmetry type should 

I choose when including the data?  

A: In order to defocus the correction, measure the pole figures of the powder sample (from the 

same material as the "textured samples", which in your case is steel). The powder sample is 

treated as a "non-texture" sample. This helps to find the absorption curve for the defocusing 

correction. The files related to the powder sample should have the extension *.POW (LaboTex 

format), *.ASC (Rigaku format) or other (for details see www.labotex.com/format.htm ). The 

files should be in the COR LaboTex directory (for the current user). In your case (the steel 

samples), you should choose the O-cubic symmetry. All symmetries are indicated according to 

the Schoenfliess symbols (International Tables for Crystallography - ed.T.Hanhn - 1983, 

D.Reidel publishing company. Dordrecht/Boston).  

 

Q: As for the powder sample should I measure it in the same condition with the ordinary 

ones?  

A: Yes. 

 

Q: Can I choose a Corr file also in the ASC format?  

A: Yes. 

 

Q: How can I have the same numerical values of the odf as in the file .pod which we had 

beefore? We need these values for our calculations to determine the stored energy.  

A: This option is available from the version 2.1 onwards (menu File-->ODF export). If you 

use version 2.0, the upgrade to version 2.1 is free of charge. For more details, please contact us 

via e-mail: office@labosoft.com.pl   

 

Q: When LaboTex reads my data file (sample.epf) I get a message "Error: Improper 

data. Check data file". Please check my input data file. 

A: Your data file is in popLA format which has the same extension as LaboTex files (.EPF). 

To make popLA *.EPF files accessible for creation of CPF files you should:  

a) select Edit->LaboTex Options;  

b) select the Data Formats tab; 

c)  select "EPF - popLA EPF files format" from the drop down lists 4 -7; 

d)  select File -> New sample  then select "epf" (small capitals!) data format (in this format the 

data is after the correction); 

e)  select your data file; 

f)  select the proper crystal symmetry for your sample. 

 

 

Q: How does LaboTex define the sample and coordinate system?  

A: LaboTex convention (from the version 2.1.006 onwards) for defining the sample and 

coordinate system is:  

1) X, Y, Z axis are perpendicular to each other,  

2) X, Y axis are in the (001) crystallographic plane and Z axis is perpendicular to (001) 

crystallographic plane,  

3) X axis is parallel to the [100] crystallographic plane,  

http://www.labotex.com/format.htm
mailto:office@labosoft.com.pl
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4) Crystal coordinate system and sample coordinate system should be at the same order i.e. 

both right-handed or both left-handed,  

5) Bunge definition of Euler angles.  

 

Q: LaboTex shows bad Euler angles for orientation (01-12)<2-201>= (012)<2-

21>={38.11,42.61,0.0}. From my diagram it should be :{38,43,30} (Zr Alloy - hexagonal 

system).  

A: Your diagram is made in a different convention than the LaboTex one. In the hexagonal 

system (for the hexagonal division: a=b,c(non equal a),alpha=beta=90,gamma=120) two 

conventions are used for the sample and coordinate system.  This is the reason for the 

difference between the values of Phi2 angle of about 30. 

In LaboTex version 2.1.008 and higher it is possible to choose the axial convention in the 

hexagonal system. 

 

Q: I have cell parameters for the trigonal system: a=b=c, alpha=beta=gamma <120. In the 

example for the trigonal system LaboTex has the same cell parameters as for the 

hexagonal system. Is this an error? 

A: No. Rhombohedral crystal can always be described in terms of hexagonal axes. In the 

trigonal division of the hexagonal system two conventions are used: (1) rhombohedral axes 

(like for your data) and (2) hexagonal axes. LaboTex uses hexagonal axes and cell parameters 

have to be the same as for the hexagonal division.  

You can find more details about the convention of cell parameters used in our report: "Pole 

Figures: Plot and Registration Conventions" available in PDF from our website 

www.labosoft.com.pl and www.labotex.com  

 

Q: The volume fraction calculated in the software does not agree with the ones I 

calculated. I calculated it by the C coefficient from the texture data.  Can you tell me how 

you calculate it?  

A: The results of the volume fraction calculation can be different due to the following reasons:  

1) When you use C coefficients with l=22 or l=34, in the case of strong texture peaks you 

obtain the truncation error of the Fourier series. This causes the error in the volume fraction 

calculation  

2) When you use C coefficients, in reality you calculate the volume of the ideal model 

components not your real experimental texture peaks. This is the second reason for the error.  

3) In LaboTex we eliminated the truncation error of the peaks by not using the harmonic series 

(the ODF calculation is based on ADC method which calculates the real ODF peaks not the 

truncated ones).  

4) In LaboTex calculates the volume fraction by integration of the real texture peaks on ODFs 

(LaboTex does not use Gauss models). Additionally users can independently decide about 

integration width of the peak in 3 Euler angles. In the case of C coefficients you are not able to 

change the different width of the Gauss model in the 3 Euler angles.  

5) You can see the comparison of different ODF calculation methods (including ADC method 

which is the base of the LaboTex software) which are described in the reference papers: The 

ADC Method References  

 

http://labotex.com/labdemo.htm
http://labotex.com/labdemo.htm
http://www.labosoft.com.pl/
http://www.labotex.com/
http://www.labotex.com/referen2.htm
http://www.labotex.com/referen2.htm
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Q: I would like to use the same values of contour pole density in the analysis of ODF for 

several samples.  Is it possible in your program?  

A: You can plot contour lines by any scale in LaboTex program.  

In order to do this:  

1. Plot any PF, ODF, or INV object using "AUTOMATIC" contours.  

2. Press the "i" icon on the program toolbar.  

3. Change the "AUTOMATIC" option to "MANUAL" in "PF isolines mode/ Load PF  

isolines".  

4.  Edit all isolines values you want in the "isolines/values" windows.  

5.  Tick the box "Value" (or/and "Color", "State").  

6.  Press the "Save PF Isolines" and save the isolines to the file.  

7.  Now, you can load these isolines from the file at any time.  

 

Q: How do you get the COR file? Where is it generated?  Can we get it from LaboSoft? 

Can I use our dbf file instead of the cor file?  

A: COR files are automatic generated when powder samples are processed (used as *.POW 

files in LaboTex - see HELP). You can create this file manual when you know the correction 

coefficients (see the manuals about LaboTex formats and pole figures conventions on our 

website www.labosoft.com.pl ). *.DBF files can be used instead of *.COR files  

 

Q: What is the meaning of rotation of the PF step, lower and upper ranges?  

A: You can rotate pole figures around the normal axis before the ODF calculation. Sometimes 

it is useful to correct the sample coordinates. Lower and upper ranges mean the ability to cut 

off the pole distance range from both sides (in the centre and in the maximum distance).  

Important! You can use simultaneously the rotation and cut off for all pole figures or 

separately for each one. Check the appropriate switch!  

 

Q: It is so difficult to use the X-ray data for every two degree scan! The reason is that we 

do a lot of work on textured thin films and 1 or 2 degrees are what would be ideal for us!  

A: There is no problem to do that. LaboTex is able to use data measured with 1 or 2 deg. step. 

The ODF calculation time will be longer of course. That is because the data set (the amount of 

data)  is bigger in that case.  

 

Q: There is a 90 deg. rotation between the PF plotted between my old texture software 

and LaboTex. 

A: There are two issues here:  

I) Different ways of pole figures plotting:  

(1) clockwise rotation from the NS direction  

(2) counterclockwise rotation from the NS direction  

(3) clockwise rotation from the WE direction  

(4) counterclockwise rotation from the WE direction  

LaboTex uses the pole figures presentation as in point A.1.  

If the ODF from LaboTex and the ODF from your old software are the same, then the 

difference is only in the pole figure presentation (a different pole figures plotting convention). 

http://www.labosoft.com.pl/
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If ODF from LaboTex and ODF from your old texture software are different then pole figures 

measurements convention are different.  

II) Different ways of registration of pole figures in the dependence from the motion of the 

texture goniometer are :  

(1) clockwise rotation from the RD direction  

(2) counterclockwise rotation from the RD direction  

(3) clockwise rotation from the TD direction  

(4) counterclockwise rotation from the TD direction  

 

LaboTex uses the convention B.1.  

You can find more details about the adjustment of LaboTex to different plot and registration 

conventions in our technical report: "Pole Figures: Plot and Registration Conventions" which is 

available on our website www.labosoft.com.pl and www.labotex.com  

 

Q: I didn't find any information about how to use the delta Phi1, Phi, Phi2 range for the 

calculation of the quantitative texture analysis. If for example I choose a phi integration 

range of 20o for a phi angle of 45 o, does it mean that the calculation will integrate in phi 

between 25 and 65 o or between 35 and 55 o? 

A: In quantitative analysis DeltaPhi1, DeltaPhi and DeltaPhi2 denote the half width of the 

integration range around the chosen orientation. So, if orientation is PHI1, PHI, PHI2, then the 

volume fraction is integrating in the range:  

[PHI1 - DeltaPhi1 , PHI1 + DeltaPhi1]  

[PHI - DeltaPhi , PHI + DeltaPhi ]  

[PHI2 - DeltaPhi2 , PHI2 + DeltaPhi2]  

Of course, you can choose different Delta for each Euler angle and for each selected orientation 

(using the view of the orientation profiles in each Euler angle cross section). The calculation 

will then integrate in Phi between 25 and 65 o for your example.  

 

Q: How can I make defocusing correction?  

A: The best way for making the defocusing correction is by measurement of a "random" 

sample. Firstly, you should take the measurement of a "random" sample just like a normal 

sample. A "random" sample has to be made from the same or similar material as the material of 

your sample. Secondly, enter the files with pole figures of the sample and the files with pole 

figures of the "random" sample simultaneously into LaboTex.  The files with pole figures of 

the "random" sample can be selected from a different list in the same dialog window. 

Preparation of a good quality "random" sample is difficult. We offer a set of "random" samples 

(texture and strain free). For more details see our website www.labosoft.com.pl section 

Prices&Orders   

 

Q: How can I check the quality of my texture measurement?  

A: The best way in this case is using the measurements of texture standards. LaboSoft offers 

texture standards of different sample symmetry which also contain a "random" sample. All  

results of measurements pole figures are provided by the Accredited Testing Laboratorie. For 

more details see our website www.labosoft.com.pl section Prices&Orders   

 

 

http://labotex.com/labdemo.htm
http://www.labosoft.com.pl/
http://www.labotex.com/
http://www.labosoft.com.pl/
http://www.labosoft.com.pl/prices__orders.htm
http://www.labosoft.com.pl/
http://www.labosoft.com.pl/prices__orders.htm
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Q: Does LaboTex cooperate with VPSC texture modeling software packages?  

A: Yes. You can input the data from a file with a set of single orientations. You can also 

generate a file which contains a set of single orientations on the base of ODFs.  

 
Q: When I run the HASP Protect Key Installation on Windows, I get the following error 

message: "user has no access to the database registry 0x20 10000 0x0 0x0"and the 

installation is stopped.  

A: In order to avoid this error when installing the HASP Protect Key on Windows 

NT/2000/XP, please follow the steps below:  

1) Switch off your PC / laptop.  

2) Plug in the HASP Protect Key into the USB slot (for earlier versions and older HASP Keys 

use the parallel printer slot).  

3) Switch your PC/ laptop on.  

4)  Login to the Windows NT/2000/XP with the Windows Administrator credentials 

(otherwise you will not be able to carry out the installation!).  

5) Install the HASP device driver. Remember to reboot the computer after the installation is 

complete.  

6) To use LaboTex you do not need the Windows Administrator credentials. These are only 

needed during the installation.  
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Specification / Feature 3.0.22 Comments  

Windows OS compatible application 

(from version 2.0. ) 

Yes  Windows  7/8/10 

Management of data and results.  Yes  Simple access to data and results. Collecting them per: users, 

symmetries, projects, samples and jobs.  

ODF calculation (direct - ADC 

Method).  

Yes  The best ODF calculation method.  

Texture analysis of all types of sample 

symmetry.  

Yes   

Texture analysis for materials of all 

types of crystal lattice symmetry.  

Yes   

Fiber texture analysis.  
Yes   

High resolution ODF option.  
Yes   

Calculation of a fit error (RP).  Yes   

Calculation of texture index.  Yes   

ODF calculation report.  Yes  Any available.  

Ghost correction.  Yes   

Truncation errors of the series.  No   

ODF calculation using pole figures.  Yes  Data from X-Ray or Neutrons measurements.  

Input data in non-LaboTex data 

format.  

Yes  LaboTex acceptes data in 31 formats. For more details see 

www.labosoft.com.pl   

Adjusting the customer data format for 

LaboTex  

Yes  Free of charge  

Correction of the pole figure for the 

background of pole figure.  

Yes   

Indicating when background values are 

greater than pole figure data values.  

Yes  LaboTex displays the percentage for the data  

Choice of the correction method for the 

background.  

Yes  When the background data of the pole figure is greater than the pole 

figure data for some values LaboTex makes:  

a) negative values of pole figure after the correction for background 

is set to zero;  

b) adds to all the pole figure data an absolute value of the lowest 

values of the pole figure after the correction for background 

(LaboTex makes all data positive). 

Option “a” is the default one. 

Correction for defocusing using 

powder pole figures.  

Yes  Correction of the powder pole figure for the background is also 

available 

Correction for defocusing from 

correction coefficients.  

Yes   

Correction for defocusing from Schulz 

equation.  

Yes   

Input data in any grid.  No  Only for radial angle: 1., 1.2 ,2. ,1.25 ,1.5, 2. ,2.5 ,3. ,3.75 ,5. ,6. ,7.5 

,10. degrees and extra: 1.8 ,2.25 ,3.6 ,4.5 but with exception of the 

trigonal and hexagonal crystal lattice symmetry. If the azimuthal 

angle step is different from the radial step, the azimuthal step is 

adjusted to the radial step by linear interpolation. Azimuthal step has 

to be in the range of 1-10 deg.  

http://www.labosoft.com.pl/format.htm
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Choice of the pole figures plot 

convention. 

Yes  Users can choose to start to plot pole figures from "N","E","S" or 

"W". Users can also adjust the description of pole figure axis (e.g. 

denotation 'RD') to the new plot convention. ODF calculations are 

independent of the choice of plot convention.  

Adjusting the pole figures registration 

convention to the LaboTex convention. 

Yes  Users can choose:  

 counter-clockwise;  

 none rotate;  

 +90 deg pole figure rotate;  

 +180 deg pole figure rotate.  

Users can set up the default for the registration convention for each 

available format of the pole figures. ODF calculations are dependent 

on the choice of the registration convention (ODF may be shifted).  

Maximal/minimal value of Miller 

indices H,K,L for input PF  

9/-9  

ODF calculation from the incomplete 

pole figure(s).  

Yes   

Indication of too small number of data 

for the ODF calculation.  

Yes  During the ODF calculation.  

ODF calculation for different 

parameters for the same sample.  

Yes  Up to 9 jobs per sample.  

Choice of the symmetrization of pole 

figures before the ODF calculation.  

Yes  Viewing of symmetrized PF.  

Choice of the sample symmetry for 

ODF (ODF symmetrization).  

Yes  Available after the ODF calculation.  

A number of the symmetrization 

possibilities.  

8  None,triclinic to monoclinic,triclinic to orthorhombic,triclinic to 

axial, monoclinic to orthorhombic, monoclinic to axial, orthorhombic 

to axial, custom to axial. 

Rotation of pole figure(s) before the 

ODF calculation.  

Yes  For all pole figures or separately for each PF in range -90 to 90 

degrees.  

Cutting off the pole figure(s) in the 

center before the ODF calculation.  

Yes  For all pole figures or separately for each PF. Users can choose the 

angle ranges.  

Cutting off the pole figure(s) in the 

edge before ODF calculation.  

Yes  For all pole figures or separately for each PF. Users can choose angle 

ranges.  

Changing the parameters finishing 

calculation in ODF calculation.  

Yes  A number of iterations (1-70), RP and dRP finishing calculation (0.1-

10%).  

Creation of complete pole figures.  Yes  Complete pole figures (RPF) are created during ODF calculations. 

Creation of complete inverse pole 

figures.  

Yes   

ODF calculation from sets of individual 

orientations (SOR).  

Yes  Data from EBSD, the model calculation and other.  

Roe/Bunge notation of the angles in 

SOR.  

Yes/Ye

s  
Notation chosen by users.  

Weights of orientations in SOR.  Yes   

Choice of ODF grid (ODF from SOR).  Yes  1x1, 1.2x1.2, 1.25x1.25, 1.5x1.5, 2x2, 2.5x2.5, 3x3, 3.75x3.75, 5x5, 

6x6, 7.5x7.5, 10x10.  

Choice of sample symmetry (ODF from 

SOR).  

No  Choice of the sample symmetry after the ODF calculation (ODF 

symmetrization).  
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Modelling of ODF, pole figures and 

inverse pole figures.  

Yes  Users can choose:  

 Crystal Symmetry;  

 Sample Symmetry:  

 Grid cells for output ODF;  

 Up to 10 components.  

 

For each texture component users can choose:  

 volume fraction;  

 FWHM for each Euler angle (phi1, phi2 and phi);  

 distribution (Gauss or Lorentz).  

Users can create any model pole figures or/and any model inverse 

pole figures from model ODF using appropriate dialog for creating 

APF (additional pole figures) or  IPF (inverse pole figures). Model 

ODF is created as a new job or as a new sample.  

Choice of methods for the 

determination of volume fraction of 

texture components.  

Yes  Users can use 2 methods: Integration and/or Model Function. 

Calculation of the volume fraction of 

texture components by Integration 

Methods.  

Yes  Up to 10 components simultaneously. 

Choice of integration ranges.  Yes  For each Euler angle separately, with the viewing. 

Evaluation of parameters of the 

component peak (Integration 

Methods). 

Yes   

Choice of the components (Integration 

Methods). 

Yes  From files or from a database.  

Choice of the method of the calculation 

of volume fraction in Integration 

Methods.  

Yes  3 methods.  

Display of orientation overlapping 

(Integration Methods).  

Yes   

Correction of overlapping (Integration 

Methods).  

Yes  Dividing ODF among overlapping orientation.  

Reporting from the calculation of the 

volume fraction of texture components 

by Integration Methods.  

Yes  Ready to print or copy to clipboard. 

Calculation of volume fraction of 

texture components by Model Function 

Methods.  

Yes  Up to 10 components simultaneously. For each texture component 

users can choose initial parameters for fitting calculation from: 

volume fraction, FWHM for each Euler angle (phi1, phi2 and phi), 

distribution (Gauss or Lorentz).  

Choice of the components (Model 

Function Methods). 

Yes  From files or from a database.  

Choice of the mode of work during 

calculation of volume fraction in Model 

Function Methods.  

Yes  Automatic and Manual ('Once' step). In the manual mode LaboTex 

calculates relative error between the experimental ODF and the 

model ODF made by the user. In the automatic mode LaboTex 

adjusts the model parameters (angles and volume fraction) to the 

optimal values.  

Comparison of the 'experimental' ODF 

with the best fit model.  

Yes  LaboTex shows the calculated and 'experimental' ODF in two modes:  

 common area - in blue color, different area - in red color;  

 'experimental' ODF - in blue color, model ODF - red line.  

Users can also save calculated ODF as a new job (Option: "Save and 

Show"). Then they can continue with the ODF comparison in 

LaboTex 'Compare Mode'. 
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Reporting the calculation of the volume 

fraction of texture components by 

Model Function Method.  

Yes  The report is available after saving the fitted model. It is ready to 

print, copy to clipboard or view. 

Components (orientations) database.  Yes  100 positions for each crystal system. The orientation introduced to 

the database is also the denotation of the component. In texture 

analysis LaboTex shows all sym. equivalent positions (orientations) 

for orientation from the database.  

Introduce orientations (components) to 

database in Miller indices ({HKL}< 

UVW>).  

Yes  Equivalent Euler angles for {HKL}< UVW> depend on the cell 

parameters when the crystal symmetry is lower than cubic. When 

users introduce an orientation (component) in the Miller indices, 

LaboTex automatically calculates Euler angles on the basis of the 

cell parameters. Hence for the samples with different cell parameters 

LaboTex shows the same orientation in the Miller indices on the 

different places in the Euler space.  

Maximal/minimal value for the  Miller 

indices H,K,L,U,V,W for orientation 

{HKL}< UVW>  

15/-15 Users can set up the maximal value for the Miller indices in the 

conversion from Euler angles (in the range 5 to 15). 

Introduce orientations (texture 

components) to the database in the 

Euler angles.  

Yes   

Introduce fiber orientations 

(components) to the database.  

Yes   

Displaying the orientation from a 

database on the ODF and PF(s).  

Yes  Selecting via a combo-box, Automatic mode, Next and Previous.  

Displaying the symmetrically 

equivalent position on the ODF and 

PF(s).  

Yes  Selecting via a combo-box or from list-box.  

Presentation of the symmetrically 

equivalent position.  

Yes  In the basic region for ODF and the full Euler space for PFs, in the 

Miller indices and Euler angles.  

On-line identification of the 

orientations (components).  

Yes  In Euler angles and Miller indices, ODF and pole figures (except 

from IPFs). In the cursor position.  

Help in finding near orientations.  Yes  Near orientations sorted by: PF/ODF,Miller indices and distance.  

Comparing the orientation analysis.  

Very useful educational purposes!  

Yes  LaboTex shows simultaneously the orientation on: ODF and ODF 

(the same and different projection), an ODF section and ODF, pole 

figure(s) and ODF, pole figure(s) and an ODF section.  

Showing ODF/PF values using a 

mouse.  

Yes  For PF LaboTex shows the sum of PF values under poles of the 

orientation and separately for the option SORT.  

Qualitative orientations analysis for 

PF/ODF.  

Yes/Ye

s  
Sorted orientations from database.  

Report from qualitative analysis.  Yes  Only for ODF. Ready to print and copy into the clipboard.  

Creation of additional, complete pole 

figures (APF) from ODF.  

Yes  User input only HKL. Available after ODF calculation.  

Creation of additional, complete 

inverse pole figures from ODF.  

Yes  User input only XYZ. Available after ODF calculation.  

Exporting ODF to ASCII format.  Yes   

Exporting Pole Figures as ASCII 

format.  

Yes   

Exporting Inverse Pole Figures to 

ASCII format.  

Yes   

Choice of the convention for the 

hexagonal system.  

Yes   

2D and 3D pole figures presentation.  Yes   
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Choice of the pole figures plot 

convention. 

Yes  Users can choose to start to plot pole figures from "N","E","S" or 

"W". Users can also adjust the description of the pole figure axis (for 

example denotation 'RD') to a new plot convention. ODF calculations 

are independent of the choice of the plot convention.  

Adjust of pole figures registration 

convention to LaboTex convention  

Yes  User can choose:  

 counter-clockwise;  

 none rotate;  

 +90 deg pole figure rotate;  

 +180 deg pole figure rotate.  

User can set up default for registration convention for each available 

format of pole figures. ODF calculation are dependent on the choice 

of registration convention (ODF may be shift).  

The maximal number of pole 

figures/inverse pole figures in one 

window.  

100   

Pole figures descriptions.  Yes  HKL, the sample name, directions (3 characters, edited by user) and 

the type of a figure (CPF,RPF,NPF,APF). 

Switching off pole figures descriptions.  Yes  Separately for each kind of description.  

Fill-in option in 2D/3D presentation.  Yes/Ye

s  
4 modes of the fill-in option: normal/black/white and continuous. 

User defined sets of colors.  Yes  15 sets.  

Isoline mode.  Yes  3 modes: automatic, manual and from user defined sets.  

Changing the parameter of the pole 

figures presentation.  

Yes  Number of isolines (maximum of 14),  color,  color set, value and 

fill-in.  

2D ODF presentation for Phi1, Phi and 

Phi2 projections.  

Yes   

2D ODF presentation for a section of a 

projection.  

Yes   

Bunge definition of the Euler angles.  Yes  ODF presentation and export.  

3D ODF presentation.  Yes   

The possibility changes of parameters 

of 3D ODF presentation.  

Yes  Rotate, distance, shift, color, axis(on,off,length),parallel/perspective 

projection, top/bottom contour, animation (cycle rotation).  

The possibility of the choice of isolines.  Yes  14  

Arrangements mode.  3  Automatic /optimal arrangements/, automatic /vertical close 

horizontal and custom.  

Drawing basic region of PF/INV.  Yes  IPF in a standard stereographic triangle (only for: cubic, hexagonal, 

trigonal and tetragonal systems) 

Saving the set of isolines.  Yes  Saved features: color, value and activity.  

Exporting 2D and 3D images to the 

bitmap format (bmp).  

Yes  BMP or TIF format available. 

Exporting (copying) 2D and 3D images 

to the clipboard.  

Yes  In the bitmap format (bmp).  

Choosing the resolution of the exported 

image.  

Yes   

Online help.  Yes   

ODF section (cuts) defined by users Yes Users can define two points in the Euler Space. LaboTex shows ODF 

intensity along the section defined by these points. Users can also 

choose initial points from an orientations database (to access the 

database select 'Start Point' or 'End Point'). Comparisons up to 12 

ODFs are available. Users can save current parameters and/or 

samples. 
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Skeleton lines Yes Users can create diagrams such as: alpha-fiber, beta-fiber, gamma 

fiber etc. Users can choose skeleton lines on the basis of the Euler 

angle (Phi1, Phi or Phi2) and :  

 maximal intensity ;  

 integral intensity.  

Users can also change ranges in which LaboTex looks for the 

maximum odf value or makes integration (from +/-2 to +/-20 deg).  

Users can compare up to 12 skeleton lines. The current parameters 

and/or samples can be saved. 

Misorientation histograms Yes Users define the starting point in the Euler Space from which 

LaboTex shows misorientation diagrams. The misorientations 

diagrams are calculated on the basis of ODFs in a range from 0 to 80 

deg from the starting point (the starting orientation). LaboTex shows 

a relative intensity i.e. this intensity is relative to the intensity of the 

random sample (I=I(sample)/I(random sample)) for the same range 

of the misorientation angle. Users can make comparison of up to 12 

misorientations histograms. Histogram steps can be changed within 

the range from 1 to 10 degrees. Current parameters and/or samples 

can be saved. 

Optimization of diagrams : ODF 

section, Skeleton lines, Misorientation 

histograms, PF section (arc, radial, 

radial-full) 

 Yes  Scale (within the percentage of the maximum intensity value: 

from 0.1% to 100%);  

 colors (defined by the user);  

 types of lines (14 types with different dots + solid pattern) ;  

 line options (all solid, all black or black contours);  

 width of lines (0 to 10 pixels);  

 diagram fill.  

 

ODFs - logical operations  Yes In order to activate this option switch LaboTex to Compare Mode, 

then choose two ODFs for comparison: one in the left window and 

the other one in the right window (LaboTex Compare Mode). On the 

basis these two ODFs (A - from the left window and B from the right 

window) LaboTex creates a new ODF which can be:  

 an intersection of the ODF A and the ODF B,  

 a difference between the ODF A and the ODF B (or B-A),  

 a union of the ODF A and the ODF B,  

 a sum of the ODF A and the ODF B,  

 a ODF difference: A or B minus the intersection of A&B,  

 an inverted ODF (only for the ODF A).  

The new ODF is created within the new job for the sample of ODF 

A. These diagrams can be copied to other applications or exported as 

images in 'BMP' or 'TIF' format (menu 'Edit'). 
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Transformations of ODF   

 

 

Yes There are two kinds transformations:  

 Frame rotations - users can rotate a sample frame along any 

Euler angles. This option gives the opportunity to see the ODF 

for other (different) sample position.  For example, to see the 

ODF for the perpendicular surface with relation to the surface 

which was measured, transform the initial ODF by Phi=90deg. 

Users can create changes of the sample symmetry for a new 

ODF.  

 Model builder rotations - (crystalites/planes rotations). Firstly, 

build a rotation model and save it. Secondly, in the rotation 

model you can choose up to 10 orientations for which you set:  

o the ranges of the Euler angle around center of orientation 

(and for symmetrically equivalent positions);  

o the vector "hkl" around which crystalites/planes will be 

rotated (only these which are included in chosen ranges);  

o the rotation angle;  

o the percentage of the rotated crystalites/planes (from 0 to 

100%).  

Now choose the rotation model and make the ODF transformation.  

LaboTex calculates the new ODF which is a result of the 

transformation of the initial ODF. 

The new ODF is created in a new job for sample of the initial ODF. 

Generation of single orientations Yes 
LaboTex creates a set of single orientations on the basis of the 

current ODF. Users can choose a number of single orientations from 

10000 to 9999999. This option is very useful for example for users 

who model deformation (VCS users). A random set of single 

orientation can be also generated using this option. *.SOR files 

created by LaboTex can be then used as a new sample for the ODF 

calculation. 

Pole figures sections (cuts) Yes Users define the starting and ending points on the pole figure and 

LaboTex shows the intensity along this section.  

The following cuts are available:  

 'Arc' (in the range of 0 to 360 degrees) ;  

 'Radial' (in the range of  0 to 90 degrees);  

 'Radial (full)' (in the range of 90 - 0 - 90 degrees).  

To see the position of the section line on the pole figure, select the 

'View' button. Up to 12 pole figures can be compared. The 

information about compared PFs is displayed in the information 

window on the left hand.  

Users must choose all pole figures for which the sections are 

displayed before pressing the ‘2D’ button. 

 If more than 12 pole figures are chosen, LaboTex shows only the 

first 12 pole figures sections. There is a number of options to 

optimize the quality of diagrams :  

 scale (the percentage of the maximum intensity value: from 

0.1% to 100%) ;  

 colors (defined by the user);  

 types of lines (14 types – dots and solid);  

 line options (all solid, all black or black contours) ;  

 lines width (from 0 to 10 pixels) ;  

 diagram ill.  

Users can save the current parameters. These diagrams can be copied 

over  to other applications or saved as images in *.BMP or *.TIF 

formats (menu 'Edit'). 

On-line view of alpha (radial angle), 

beta (azimuthal angle) and pole figure 

value using the mouse cursor. 

Yes 
LaboTex displays this data in the format: (alpha,beta) PF='value of 

PF'. 
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User defined grid for pole figures. Yes 
Users can define a grid for the alpha angle and/or a grid for the beta 

angle of PF. 

User Manuals and Technical Reports.  Yes   Short Introduction to LaboTex  

 Menu and Toolbars Commands Description 

 Determination of the Volume Fraction of Texture 

Components Using LaboTex - Integration Methods  

 Determination of the Volume Fraction of Texture 

Components Using LaboTex - Model Functions Method  

 Pole Figures: Registration and Plot Conventions  

 Nomenclature of the Inverse Pole Figures in  LaboTex  

 LaboTex: Modelling of ODF, Pole Figures and Inverse Pole 

Figures  

Usage examples.  Yes  The following examples are available:  

 Examples for all crystal symmetry. 

 Examples for all sample symmetry.  

 Example for high resolution pole figures and ODFs (1x1 

deg).  

 Examples for the fibre texture (in the demo version). 

 Additional examples (available on our website 

www.labosoft.com.pl)  

Demo version.  Yes  The demo version is based on the version 2.1.012 

Support.  Yes  Free full e-mail support and updates for 24 months 

Protection.  Yes  HASP Key: Parallel Port or USB socket. 

Minimal system configuration.   Processor PENTIUM IV 2 GHz or higher; 

 1 GB HD space; 

 graphic card resolution 1024x768; 

 CD-ROM drive; 

 OpenGL Graphic Card is required for 3D View in "Continuous" 

fill mode; 

 USB port. 

Recommended system configuration.   Processor Intel Core I5 or I7; 

 20-50 GB HD space;  

 4 GB RAM;  

 graphic card resolution 1920x1200 + OpenGL 

 USB port;  

 color laser jet or inkjet printer,   

 if data are measured in the grid less than 5x5 degrees, double 

free disk space  is recommended. 
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